Bug 12765 - 'make' bug suspected
'make' bug suspected
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: make (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-20 13:14 EDT by Clyde Spencer
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-20 13:14:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clyde Spencer 2000-06-20 13:14:06 EDT
I attempted to recompile my 2.2.14-5.0 kernel to get SCSI emulation to
support my Memorex CDRW 2216 CD-R write capability.  After running "make
menuconfig" and "make dep" with no apparent problems, I then ran "make
bzImage".  I received the following output immediately:
gcc -Wall-Wstrict-prototypes -02 -fomit-frame-pointer -o scripts/split-
include scripts/split-include.c In file include from 
usr/include/errno.h:36,from scripts/split-include.c:26: 
/usr/include/bits/errno.h:25
linux/errno.h: No such file or directory
make:***[scripts/split-include]Error 1.

Also, I had previously attempted to compile a package from the Univ. of 
Maryland and ran into a problem running 'make.'  After several lines that 
seemed to be alright, I then received the following:
make[1]: @SHELL@: Command not found
make[1]: ***[xxxAllooCopy.o] Error 127
make[1]: Leaving directory 'usr/local/lpgs/lpgslite/xxxLIB'
make: *** [all-recursive] Error 1

I'm running a recent install on a 233 MHz Cyrix CPU with 64 MB simm memory 
and 20 Gb hardrive.

Clyde Spencer
Comment 1 Jeff Johnson 2000-07-22 08:27:54 EDT
There are 2 problems here, neither with make:

1) linux/errno.h: No such file or directory
	This is usually caused by a missing /usr/include/linux symlink. The following
command
	should fix:
		ln -sf  ../src/linux/include/linux/ /usr/include/linux
	You should probably do and/or check
		ln -sf ../src/linux/include/asm /usr/include/asm
	as well

2)  make[1]: @SHELL@: Command not found
	This problem is usually caused by a misgenerated autoconf/automake file that
	was expanded by the wrong version of autoconf/automake. Install later versions
	of autoconf/automake and regenerate Makefile.in files

Note You need to log in before you can comment on or make changes to this bug.