This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1276538 - [exportfs] exportfs -u cannot unexport when the specified path involves a trailing "/"
[exportfs] exportfs -u cannot unexport when the specified path involves a tra...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
Milan Navratil
:
Depends On: 1276534
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 23:55 EDT by Yongcheng Yang
Modified: 2017-03-21 07:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.3-73.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1276534
Environment:
Last Closed: 2017-03-21 07:23:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yongcheng Yang 2015-10-29 23:55:22 EDT
+++ This bug was initially created as a clone of Bug #1276534 +++

Description of problem:
When using "exportfs -u" to unexport just one directory, it always failed when the specified path involves a trailing "/", with error:
exportfs: Could not find 'client.example.com:/export/' to unexport.

Version-Release number of selected component (if applicable):
nfs-utils-1.2.3-64.el6

How reproducible:
100%

Steps to Reproduce:
1. exportfs -v $HOSTNAME:/export/
2. exportfs -u client2.example.com:/export/

Actual results (for RHEL6):
[root@ibm-x3650m4-08 ~]# exportfs -o rw,sync $HOSTNAME:/export/
[root@ibm-x3650m4-08 ~]# exportfs -v
/export       	ibm-x3650m4-08.rhts.eng.pek2.redhat.com(rw,wdelay,root_squash,no_subtree_check,sec=sys,rw,root_squash,no_all_squash)
[root@ibm-x3650m4-08 ~]# exportfs -u ibm-x3650m4-08.rhts.eng.pek2.redhat.com:/export/
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ failed
[root@ibm-x3650m4-08 ~]# echo $?
0
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ should not return 0 as bz 1276221 said
[root@ibm-x3650m4-08 ~]# exportfs -v
/export       	ibm-x3650m4-08.rhts.eng.pek2.redhat.com(rw,wdelay,root_squash,no_subtree_check,sec=sys,rw,root_squash,no_all_squash)
[root@ibm-x3650m4-08 ~]# exportfs -u ibm-x3650m4-08.rhts.eng.pek2.redhat.com:/export
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ success without trailing "/"
[root@ibm-x3650m4-08 ~]# echo $?
0
[root@ibm-x3650m4-08 ~]# exportfs -v
[root@ibm-x3650m4-08 ~]# rpm -q nfs-utils
nfs-utils-1.2.3-64.el6.x86_64
[root@ibm-x3650m4-08 ~]# 


Expected results:
Unexport success

Additional info:
Comment 4 Yongcheng Yang 2016-10-31 20:26:19 EDT
Moving to VERIFIED according to Comment #3.

And will include this automatic case as regression test.
Comment 9 errata-xmlrpc 2017-03-21 07:23:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0741.html

Note You need to log in before you can comment on or make changes to this bug.