This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1276542 - RHGS-3.1.2 op-version need to be corrected
RHGS-3.1.2 op-version need to be corrected
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 3.1.2
Assigned To: Satish Mohan
Byreddy
glusterd
: ZStream
Depends On: 1230764
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-10-30 01:18 EDT by Anand Nekkunti
Modified: 2016-03-21 05:12 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1230764
Environment:
Last Closed: 2016-03-01 00:49:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Nekkunti 2015-10-30 01:18:43 EDT
+++ This bug was initially created as a clone of Bug #1230764 +++

The op-versions for RHGS-3.1 need to be corrected to match RHS-3.0, so that backwards compatibility is retained for RHS-3.0 and older servers and clients.

--- Additional comment from Kaushal on 2015-06-11 10:02:43 EDT ---

Change has been posted for review at https://code.engineering.redhat.com/gerrit/50555/

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-06-11 12:35:19 EDT ---

Since this bug has been approved for the Red Hat Gluster Storage 3.1.0 release, through release flag 'rhgs-3.1.0+', the Target Release is being automatically set to 'RHGS 3.1.0'

--- Additional comment from SATHEESARAN on 2015-06-12 01:40:15 EDT ---

Raising this issue as a BLOCKER emphasizing that this patch should be taken for RHGS 3.1 ( Everglades ) Release

--- Additional comment from Rejy M Cyriac on 2015-06-15 01:48:02 EDT ---

Moving to ON_QA as this BZ has entry at the change log for glusterfs-3.7.1-3 build

------------------------------------------------------------
Changelog 	* Mon Jun 15 2015 Bala.FA <barumuga@redhat.com> - 3.7.1-3
- fixes bugs bz#1211839 bz#1224046 bz#1224236 bz#1224662 bz#1224880 
  bz#1225507 bz#1226889 bz#1227618 bz#1228017 bz#1228495 bz#1228597 bz#1229623 
  bz#1229674 bz#1230607 bz#1230764 bz#1231078
------------------------------------------------------------

--- Additional comment from SATHEESARAN on 2015-06-23 11:46:07 EDT ---

Tested RHGS 3.1 nightly ISO ( http://download.eng.bos.redhat.com/composes/nightly/RHGSS-3.1-20150619.n.1/3/RHS/x86_64/iso/RHGSS-3.1-20150619.n.1-RHS-x86_64-DVD1.iso ) [ glusterfs-3.7.1-4.el6rhs ] 

The default op-version of the cluster after installation was 30702

Marking this bug as VERIFIED

--- Additional comment from errata-xmlrpc on 2015-07-29 01:02:26 EDT ---

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2015-1495.html
Comment 3 Anand Nekkunti 2015-10-30 01:34:00 EDT
patch: https://code.engineering.redhat.com/gerrit/#/c/60485/
Comment 5 Byreddy 2015-11-17 23:22:11 EST
verified this bug with latest 3.1.2 build (glusterfs-3.7.5-6).

The op-version set properly that is 

[root@ ~]# gluster volume get Dis cluster.op-version
Option                                  Value                                   
------                                  -----                                   
cluster.op-version                      30706                                   
[root@ ~]# 

moving to verified state.
Comment 10 errata-xmlrpc 2016-03-01 00:49:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.