Bug 127664 - mozilla doesn't honour disabling of hide-tabbar pref
mozilla doesn't honour disabling of hide-tabbar pref
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-12 07:16 EDT by Mike A. Harris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.7.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 21:43:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2004-07-12 07:16:19 EDT
Problem:
Mozilla's tab preferences have an option named:

[x] Hide the tab bar when only one tab is open.

It defaults to being enabled as above, however if you clear the
checkbox, thus disabling the preference, quit mozilla and start
it back up again, mozilla starts up with your default page in a
browser window, with no visible tab bar.  It ignores the
preference at startup time essentially.  Once you have opened a
new tab up, either by clicking on "File->New-New browser tab" or
hitting CTRL-T, the tab bar appears and stays there as expected.

Version: 
FC1 mozilla-1.4.1-18 (however all versions of mozilla seem to do this)


Expected behaviour:
When the above preference is turned off, the browser should start
up with a visible tab bar right away, and open the default page
in the first tab.  This allows you to use the right click tabbar
menu to open new tabs, close them, etc.
Comment 1 John Thacker 2006-04-21 21:43:05 EDT
This was fixed at some point.  Certainly works for me on 1.7.12

Note You need to log in before you can comment on or make changes to this bug.