Bug 1276661 - Doc: ip-neighbour man page and ip neighbour help issues
Doc: ip-neighbour man page and ip neighbour help issues
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Phil Sutter
Jaroslav Aster
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 08:09 EDT by Jaroslav Aster
Modified: 2016-11-03 19:36 EDT (History)
0 users

See Also:
Fixed In Version: iproute-3.10.0-70.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:36:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Aster 2015-10-30 08:09:20 EDT
Description of problem:

This bug describes several issues which was founded in ip-neighbour manpage and ip neighbour help.


Version-Release number of selected component (if applicable):

iproute-3.10.0-54.el7


How reproducible:

100%


1,

There are bad offsets of starts of description of commands ip neighbour delete/show/flush in ip-neighbour man page.

       stale  the neighbour ...
              ip neighbour delete - delete a neighbour entry
       This command invalidates a neighbour entry.


       Warning: Attempts to ...
       interface or if the address is multicast or broadcast.

              ip neighbour show - list neighbour entries

       This command displays neighbour tables.


       nud NUD_STATE
              only list neighbour ...

              ip neighbour flush - flush neighbour entries

       This command flushes neighbour tables, selecting entries to ...

The fix is easy.

2,

ip neighbour recognises 9 nud states: permanent, reachable, noarp, none, stale, incomplete, delay, probe, failed, but not all are mentioned in ip neighbour man page or ip neigh help.

The fix is easy.
Comment 1 Jaroslav Aster 2015-10-30 12:25:41 EDT
Founded issues:

:: [   FAIL   ] :: Checking there is 'all' in ip neighbour help. (Expected 0, got 1)
:: [   FAIL   ] :: Checking there is 'unused' in ip neighbour help. (Expected 0, got 1)

all and unused are used in flush and show commands.

:: [   FAIL   ] :: Checking there is 'probe' in ip neighbour help. (Expected 0, got 1)
:: [   FAIL   ] :: Checking there is 'probe' in ip-neighbour man page. (Expected 0, got 1)
:: [   FAIL   ] :: Checking there is 'failed' in ip neighbour help. (Expected 0, got 1)
:: [   FAIL   ] :: Checking there is 'failed' in ip-neighbour man page. (Expected 0, got 1)
:: [   FAIL   ] :: Checking there is 'incomplete' in ip neighbour help. (Expected 0, got 1)
:: [   FAIL   ] :: Checking there is 'incomplete' in ip-neighbour man page. (Expected 0, got 1)
:: [   FAIL   ] :: Checking there is 'delay' in ip neighbour help. (Expected 0, got 1)
:: [   FAIL   ] :: Checking there is 'delay' in ip-neighbour man page. (Expected 0, got 1)
:: [   FAIL   ] :: Checking there is 'none' in ip neighbour help. (Expected 0, got 1)

probe, failed, incomplete delay and none are nud states.
Comment 2 Phil Sutter 2016-01-12 12:08:12 EST
The following upstream commit fixes the first issue:

commit 882e754cd4b3f302714bae777ee674fe6c61d04b
Author: Stephen Hemminger <stephen@networkplumber.org>
Date:   Mon Mar 31 20:23:40 2014 -0700

    fix indentation of ip neighbour man page
    
    Formatting was awful and unclear on ip neighbour

The second issue still needs to be fixed upstream.
Comment 5 Jaroslav Aster 2016-07-21 10:08:44 EDT
(In reply to Phil Sutter from comment #2)
> 
> The second issue still needs to be fixed upstream.

Understand, but help and man-page are still inconsistent so switching it to assigned state.


man-page:

       STATE := { permanent | noarp | stale | reachable | none | incomplete | delay | probe | failed }


help:

          [ nud { permanent | noarp | stale | reachable } ]
Comment 8 errata-xmlrpc 2016-11-03 19:36:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2162.html

Note You need to log in before you can comment on or make changes to this bug.