Bug 1276667 - CLI console shutdowns JBOSS whith tomcat native libraries use (and others troubles)
CLI console shutdowns JBOSS whith tomcat native libraries use (and others tro...
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CLI, Apache Server (httpd) and Connectors (Show other bugs)
6.4.2
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: jboss-set
Petr Kremensky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 08:38 EDT by nicolas.mengin
Modified: 2017-07-27 15:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 15:15:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nicolas.mengin 2015-10-30 08:38:06 EDT
Description of problem:

I try to configure a HTTPS connector with SSL files in PEM format.
That's why I have to use Tomcat native libraries. But when I launch commands line to configure web subsystem and reload JBoss the server shutdowns then its process becomes a zombie process.

Version-Release number of selected component (if applicable):

JBOSS-EAP-6.3.3 and JBOSS-EAP-6.4.2

How reproducible:

Always

Steps to Reproduce:

1. Install tomcat-native libraries :  

yum install tomcat-native

2. Create a script ~/init-native-jboss.cli which contains these commands :

# ADDING AJP thread-pool
/subsystem=threads/thread-factory=ajp-connector-factory/:add(thread-name-pattern=AJP-%t,group-name=ajp-thread-pool,priority=9)
/subsystem=threads/unbounded-queue-thread-pool=ajp-thread-pool/:add(max-threads=42,keepalive-time={time=42, unit="seconds"},thread-factory=ajp-connector-factory)
reload
# ADDING HTTP thread-pool
/subsystem=threads/thread-factory=http-connector-factory/:add(thread-name-pattern=HTTP-%t,group-name=http-thread-pool,priority=9)
/subsystem=threads/unbounded-queue-thread-pool=http-thread-pool/:add(max-threads=42,keepalive-time={time=42, unit="seconds"},thread-factory=http-connector-factory)
reload
# CONFIGURE web subsystem to use native libraries
/subsystem=web/:write-attribute(name=native, value=true)

3. Execute the script into cli console : $JBOSS_HOME/bin/jboss-cli.sh -c --user=foo --password=bar --file=~/init-native-jboss.cli
4. Restart JBoss.
5. Create a script ~/init-connectors-jboss.cli which contains these commands :

# CONFIGURE AJP connector
/subsystem=web/connector=ajp13/:add(socket-binding=ajp,scheme=http,protocol=org.apache.coyote.ajp.AjpAprProtocol,executor=ajp-thread-pool)
# CONFIGURE HTTP connector
/subsystem=web/connector=http/:write-attribute(name=executor, value=http-thread-pool)
/subsystem=web/connector=http/:write-attribute(name=protocol, value=org.apache.coyote.http11.Http11Protocol)
reload
# ADDING HTTPS connector with SSL configuration
/subsystem=web/connector=https/:add(socket-binding=https,scheme=https,protocol=org.apache.coyote.http11.Http11AprProtocol,enable-lookups=false,secure=true,executor=http-thread-pool)
/subsystem=web/connector=https/ssl=configuration:add(name=lyra-ssl, password=changeit, certificate-key-file=/etc/pki/tls/private/foo.key, certificate-file=/etc/pki/tls/certs/foo.crt, protocol=TLSv1)
reload

6. Execute the script into cli console : $JBOSS_HOME/bin/jboss-cli.sh -c --user=foo --password=bar --file=~/init-connectors-jboss.cli

Actual results:

INFO  [org.apache.coyote.http11.Http11AprProtocol] (MSC service thread 1-4) JBWEB003075: Coyote HTTP/1.1 pausing on: http-/0.0.0.0:8443
INFO  [org.apache.coyote.http11.Http11AprProtocol] (MSC service thread 1-4) JBWEB003077: Coyote HTTP/1.1 stopping on : http-/0.0.0.0:8443
INFO  [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-3) JBWEB003075: Coyote HTTP/1.1 pausing on: http-/0.0.0.0:8080
INFO  [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-3) JBWEB003077: Coyote HTTP/1.1 stopping on : http-/0.0.0.0:8080
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f5ee0fbfde0, pid=4606, tid=140045364762368
#
# JRE version: OpenJDK Runtime Environment (8.0_51-b16) (build 1.8.0_51-b16)
# Java VM: OpenJDK 64-Bit Server VM (25.51-b03 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libssl.so.10+0x44de0]  SSL_new+0x10
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid4606.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

Expected results:

Restarted server.

Additional info:

This configuration works well if the standalone.xml is directly edited, the problem is only with the CLI console.
Comment 1 nicolas.mengin 2015-11-10 10:58:39 EST
I still have the problems.

Currently I deleted all the reload actions from my CLI scripts.
I use a shell script which calls all the CLI scripts and it executes a jboss restart commands when necessary.

I presume the problem is the CLI reload methods but I can't go far for the moment.
Comment 3 nicolas.mengin 2015-11-19 05:54:43 EST
Do you need more information about this problem?
In this case, what kind of information?
Comment 5 Jean-frederic Clere 2016-06-22 07:36:34 EDT
The /tmp/hs_err_pid4606.log might help to have a clue...

The SSL_new() looks weird there as if the connector was stopping and using SSL to do so. (The unlock socket logic).
Comment 6 Brad Maxwell 2017-07-27 15:15:19 EDT
Closing as this looks like a support request not a bug.  Support requests should be handled via https://access.redhat.com/support/cases/ , if you do not have support, then you can reach out to community forums

Note You need to log in before you can comment on or make changes to this bug.