Bug 1276675 - Arbiter volume becomes replica volume in some cases
Arbiter volume becomes replica volume in some cases
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks: 1276907
  Show dependency treegraph
 
Reported: 2015-10-30 09:10 EDT by Pranith Kumar K
Modified: 2016-06-16 09:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1276907 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:42:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2015-10-30 09:10:43 EDT
Description of problem:
    Problem:
    1) Glusterd doesn't remember about arbiter information of replica volume in
       store.  When glusterd goes down and comes backup, arbiter volumes will
       become replica volumes.
    
    2) Glusterd doesn't import/export arbiter information to/from the other peers.
    
    3) Volume info doesn't show any arbiter count in the output.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-10-30 09:11:31 EDT
REVIEW: http://review.gluster.org/12475 (mgmt/glusterd: Store arbiter-count and restore it) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2015-11-01 01:20:19 EST
REVIEW: http://review.gluster.org/12475 (mgmt/glusterd: Store arbiter-count and restore it) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2015-11-01 02:32:53 EST
REVIEW: http://review.gluster.org/12475 (mgmt/glusterd: Store arbiter-count and restore it) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Vijay Bellur 2015-11-01 21:34:58 EST
REVIEW: http://review.gluster.org/12475 (mgmt/glusterd: Store arbiter-count and restore it) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Niels de Vos 2016-06-16 09:42:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.