Bug 1276680 - SELinux is preventing abrt-hook-ccpp from 'read' accesses on the file /usr/libexec/packagekitd.
SELinux is preventing abrt-hook-ccpp from 'read' accesses on the file /usr/li...
Status: CLOSED DUPLICATE of bug 1276931
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:fda9e116cc1be05c242e682330e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 09:31 EDT by istaff
Modified: 2015-11-09 01:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 01:40:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description istaff 2015-10-30 09:31:38 EDT
Description of problem:
SELinux is preventing abrt-hook-ccpp from 'read' accesses on the file /usr/libexec/packagekitd.

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que abrt-hook-ccpp devrait être autorisé à accéder read sur packagekitd file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:rpm_exec_t:s0
Target Objects                /usr/libexec/packagekitd [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           PackageKit-1.0.10-1.fc22.x86_64
Policy RPM                    selinux-policy-3.13.1-128.18.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-200.fc22.x86_64 #1 SMP Thu
                              Oct 8 03:23:55 UTC 2015 x86_64 x86_64
Alert Count                   3
First Seen                    2015-10-30 12:21:25 CET
Last Seen                     2015-10-30 12:25:56 CET
Local ID                      5817e7cf-d197-47d6-894b-9a22c66f736f

Raw Audit Messages
type=AVC msg=audit(1446204356.250:592): avc:  denied  { read } for  pid=3167 comm="abrt-hook-ccpp" name="packagekitd" dev="dm-1" ino=1049889 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:rpm_exec_t:s0 tclass=file permissive=0


Hash: abrt-hook-ccpp,abrt_dump_oops_t,rpm_exec_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-128.18.fc22.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-200.fc22.x86_64
type:           libreport
Comment 1 istaff 2015-11-02 14:22:02 EST
Description of problem:
can't open gnome software for updating fedora22. 

Version-Release number of selected component:
selinux-policy-3.13.1-128.18.fc22.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-200.fc22.x86_64
type:           libreport
Comment 2 Miroslav Grepl 2015-11-09 01:40:16 EST

*** This bug has been marked as a duplicate of bug 1276931 ***

Note You need to log in before you can comment on or make changes to this bug.