Bug 1276721 - virt-builder unable to parse index.asc from libguestfs.org
virt-builder unable to parse index.asc from libguestfs.org
Status: CLOSED DUPLICATE of bug 1194472
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 12:01 EDT by Jason Boyer
Modified: 2015-10-30 12:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 12:10:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Boyer 2015-10-30 12:01:00 EDT
Description of problem:
debian-7 is listed twice in the index.asc file downloaded from libguestfs.org by virt-builder and this causes virt-builder to discard the entire file.

Version-Release number of selected component (if applicable):
Ubuntu Trusty packaged version 1.24.5

How reproducible:
Every time

Steps to Reproduce:
1. install libguestfs-tools via whatever method you prefer
2. virt-builder -l


Actual results:
This error message:
virt-builder: index is corrupt: os-version 'debian-7' appears two or more times

The index file downloaded from 'http://libguestfs.org/download/builder/index.asc' is corrupt.
You need to ask the supplier of this file to fix it and upload a fixed version.

Expected results:
List of available templates
Comment 1 Richard W.M. Jones 2015-10-30 12:10:12 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1194472#c2
https://bugs.launchpad.net/ubuntu/+source/libguestfs/+bug/1433750

*** This bug has been marked as a duplicate of bug 1194472 ***

Note You need to log in before you can comment on or make changes to this bug.