Bug 1276726 - Omnikey 3121 with PID 0x3022 support
Omnikey 3121 with PID 0x3022 support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ccid (Show other bugs)
6.8
All Linux
high Severity high
: rc
: ---
Assigned To: Bob Relyea
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 12:07 EDT by Eugene Keck
Modified: 2016-05-10 20:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: ccid-1.3.9-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:24:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated Info.plist (27.62 KB, text/plain)
2016-01-05 15:08 EST, Bob Relyea
no flags Details

  None (edit)
Description Eugene Keck 2015-10-30 12:07:58 EDT
Description of problem:
Updated Omnikey 3121 with PID 0x3022 not supported in ccid

Version-Release number of selected component (if applicable):
ccid-1.3.9-6.1.el6_5

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Bus 002 Device 010: ID 076b:3022 OmniKey AG

From HID Global:

0x3022 is the new PID reflecting a firmware change to version 2.04. It should work fine with the latest OMNIKEY proprietary Windows drivers and native CCID class drivers.

ccid v 1.4.18 and greater supports OMNIKEY 3021 with pid 3022. It is really just about making the PID part of the supported reader list that's compiled into ccidlib at build time.

According to https://alioth.debian.org/frs/?group_id=30105#title_ccid the latest version is  1.4.20
Comment 4 Bob Relyea 2015-11-12 13:22:19 EST
I've ordered the hardware. I ordered two devices so I can send on to QA as well.

dev+
Comment 6 Asha Akkiangady 2015-11-17 12:23:34 EST
Providing qa_ack+ based on the QE hardware requirement to be fulfilled as per comment 4.
Comment 7 Bob Relyea 2015-11-17 18:34:57 EST
Asha, hardware is on it's way.
Comment 9 Asha Akkiangady 2015-11-23 08:35:16 EST
Bob, Thanks. Received Omnikey 3121 reader today.
Comment 13 Bob Relyea 2016-01-05 15:08 EST
Created attachment 1111930 [details]
Updated Info.plist

This would instll in /usr/lib{64}/pcsc/drivers/ifd-ccid.bundle/Contexts/Info.plist
Comment 14 Bob Relyea 2016-01-07 11:56:14 EST
fixed in ccid-1.3.9-8.el6
Comment 16 Roshni 2016-01-27 14:09:17 EST
PIV and SC650 cards (SCP01 and SCP02) are not being detected by ESC when inserted in the reader.

PIV cards 1,9 and 16 were detected by ESC with this reader.
Comment 17 Bob Relyea 2016-01-28 15:19:26 EST
This sounds like a multi-voltage issue. I wouldn't expect the new Omnikey to fail here. I'll double check.
Comment 18 Bob Relyea 2016-01-29 17:46:25 EST
It's a T0 versus T1 issue. The Omnikey has a weird T1 mode which we have special code to turn on. The code was enabling T1 for the new reader, but not the new code. fixed in ccid-1.3.9-9.el6 .
Comment 20 Roshni 2016-02-01 16:32:10 EST
[root@dhcp129-123 ~]# rpm -qi ccid
Name        : ccid                         Relocations: (not relocatable)
Version     : 1.3.9                             Vendor: Red Hat, Inc.
Release     : 9.el6                         Build Date: Fri 29 Jan 2016 05:45:29 PM EST
Install Date: Mon 01 Feb 2016 12:45:33 PM EST      Build Host: x86-027.build.eng.bos.redhat.com
Group       : System Environment/Libraries   Source RPM: ccid-1.3.9-9.el6.src.rpm
Size        : 420418                           License: LGPLv2+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://pcsclite.alioth.debian.org/ccid.html
Summary     : Generic USB CCID smart card reader driver
Description :
Generic USB CCID (Chip/Smart Card Interface Devices) driver.

[root@dhcp129-123 ~]# rpm -qi coolkey
Name        : coolkey                      Relocations: (not relocatable)
Version     : 1.1.0                             Vendor: Red Hat, Inc.
Release     : 37.el6                        Build Date: Fri 29 Jan 2016 02:51:15 PM EST
Install Date: Mon 01 Feb 2016 12:44:43 PM EST      Build Host: x86-031.build.eng.bos.redhat.com
Group       : System Environment/Libraries   Source RPM: coolkey-1.1.0-37.el6.src.rpm
Size        : 242406                           License: LGPLv2
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://directory.fedora.redhat.com/wiki/CoolKey
Summary     : CoolKey PKCS #11 module
Description :
Linux Driver support for the CoolKey and CAC products.


Gemalto 64K smartcard, SC650 (SCP01 and SCP02), SC330J, CAC cards, PIV card (1-16), Oberthur smartcard were successfully detected by the reader. The certificates on the cards were listed using ESC, Firefox and smartcard test tool.

pklogin_finder and gdm login using Gemalto cards and CAC cards were also successful.
Comment 23 errata-xmlrpc 2016-05-10 20:24:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0900.html

Note You need to log in before you can comment on or make changes to this bug.