Bug 1276769 - [RFE] RBAC Control create_repository
[RFE] RBAC Control create_repository
Status: CLOSED DUPLICATE of bug 1410916
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.1.3
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks: 1316897
  Show dependency treegraph
 
Reported: 2015-10-30 16:05 EDT by Karl Abbott
Modified: 2018-07-18 13:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-07-18 13:49:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 18133 None None None 2017-01-18 09:05 EST

  None (edit)
Description Karl Abbott 2015-10-30 16:05:40 EDT
What problem/issue/behavior are you having trouble with?  What do you expect to see?

Within the 'Product and Repositories'  RBAC Resource type, there are options to view, create, edit, destroy and sync products. However there do not seem to be any controls to allow the same actions for repositories. 

We are permissioning users and teams to their own Product. We want to allow users to be able to CREATE their own repositories in this product but DENY them the ability to CREATE products.

(Products / Repositories seem to share the same permissions?).

I want to see the:

view_repositories
create_repositories
edit_repositories
destroy_repositories

Permissions so that users can create / modify repositories they have access to but be denied the ability to create more products.
Comment 3 Bryan Kearney 2016-07-08 16:22:22 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 6 Ondřej Pražák 2017-01-18 09:05:21 EST
Created redmine issue http://projects.theforeman.org/issues/18133 from this bug
Comment 7 Bryan Kearney 2018-07-18 13:49:45 EDT

*** This bug has been marked as a duplicate of bug 1410916 ***

Note You need to log in before you can comment on or make changes to this bug.