Bug 1276776 - [f23] docker 1.7.0 can't bind mount root dir into container
[f23] docker 1.7.0 can't bind mount root dir into container
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 16:53 EDT by Dusty Mabe
Modified: 2015-11-05 10:12 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 10:12:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dusty Mabe 2015-10-30 16:53:40 EDT
Description of problem:

For many super privileged containers we need to bind mount the root of the filesystem into the container. We can't do this with docker docker-1.7.0-22.gitdcff4e1.fc23.x86_64. This should not be a long lived bug since docker 1.8 (which does not have this problem) will land shortly after release but we needed a BZ for common bugs. 


```
-bash-4.3# rpm -q docker
docker-1.7.0-22.gitdcff4e1.fc23.x86_64
-bash-4.3# docker run -it --rm --privileged -v /:/host busybox
Error response from daemon: Relabeling of / is not allowed
-bash-4.3#
```
Comment 1 Dusty Mabe 2015-10-30 16:54:04 EDT
please close this once 1.8 hits table repos.
Comment 2 Mike Ruckman 2015-10-30 18:46:24 EDT
Updated the CommonBugs page with this.
Comment 3 Dusty Mabe 2015-11-05 10:12:16 EST
docker 1.8 is in the repos now. can close this bug.

Note You need to log in before you can comment on or make changes to this bug.