Bug 127682 - gtk2 applications have memory leak
gtk2 applications have memory leak
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-12 11:26 EDT by Bryan Christ
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 01:46:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Christ 2004-07-12 11:26:28 EDT
Description of problem:
Several gtk2 applications experience memory leaks.  Noteworthy
applications include Evolution, Galeon, Epiphany, and Anjta.

Version-Release number of selected component (if applicable):


How reproducible:
The easiest way to reproduce this problem is by using one of the web
browsers like Galeon or Epiphany.  Open up the browser and the
gnome-system-monitor to watch the memory consumption increase.  Next
browse 30-60 DIFFERENT web pages.  A marked increase in memory usage
should be evident.  Also notices that closing the web pages (if you
are using tabbed browsing) does not free the memory.  Only closing the
application releases the memory.  Heavy email usage will also evidence
the same thing in Evolution.  This problem does not happen on Mozilla
or Firefox which eliminates the gecko rendering engine as the cluprit.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
This problem has seen on every machine I have tried which is now
nearly half a dozen systems.  The current system is using the NVidia
GLX binary driver but the same problem is evident using the opensource
nv driver.  GTK is currently package version gtk2-2.4.0-1 but the
problem has been seen on previous versions of gtk2.
Comment 1 Matthias Clasen 2004-07-14 14:05:19 EDT
> The easiest way to reproduce this problem is by using one of the web
> browsers like Galeon or Epiphany.  Open up the browser and the
> gnome-system-monitor to watch the memory consumption increase.  Next
> browse 30-60 DIFFERENT web pages.  A marked increase in memory usage
> should be evident.  Also notices that closing the web pages (if you
> are using tabbed browsing) does not free the memory. 

This is not a useful test case. Browsers are huge applications
containing many caches, which could be responsible for the increased
memory consumption you see. If you can demonstrate a memory leak in
say gtk-demo, it would be much more likely to be a problem in gtk.
Comment 2 Bryan Christ 2004-07-14 14:28:53 EDT
Okay.  Using gtk-demo I was able to go from 14.4MB when the
application was first launched to 21.2MB in about 3 minutes. 
Basically, I opened the "images" and then closed it.  Then, I opened
"pixbufs" and closed it.  Then I opened "text widget->multiple views"
and closed it.  I repeated this procedure about 15 times.
Comment 3 Bryan Christ 2004-07-15 11:02:54 EDT
I assume that it is fair to reopen this issue with the data from gtk-demo.
Comment 4 Matthias Clasen 2004-09-22 01:46:58 EDT
This was due to a memory leak in the pixbufs example of gtk-demo,
which has been fixed upstream.
Comment 5 Bryan Christ 2004-09-22 10:04:04 EDT
Are you saying this was a gdk-pixbuf issue or a problem specific to
gtk-demo?
Comment 6 Matthias Clasen 2004-09-22 10:25:17 EDT
I found a problem in the pixbufs example of gtk-demo, not a generic
gdk-pixbuf issue.

Note You need to log in before you can comment on or make changes to this bug.