Bug 1276827 - OpenMP support for Clang/++
OpenMP support for Clang/++
Status: CLOSED DUPLICATE of bug 1342815
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Včelák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 21:35 EDT by Darcy
Modified: 2016-06-05 10:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: OpenMP support
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-05 10:24:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case (160 bytes, text/x-csrc)
2015-11-06 21:26 EST, Darcy
no flags Details

  None (edit)
Description Darcy 2015-10-30 21:35:13 EDT
Description of problem:
No OpenMP headers or libomp included with the Clang/++ compiler in the Fedora package.

Version-Release number of selected component (if applicable):
3.5 and tested on 3.7.

How reproducible:
Trivial. 

Steps to Reproduce:
1. Write some code with a #pragma omp parallel section
2. Compile using clang -fopenmp main.cpp -o test.out
3. Terminal output does not generate multiple threads

Actual results:
Only one thread prints out test message

Expected results:
Multiple threads print out hello world

Additional info:
The clang compiler links against gomp (checked using ldd).  There is no header in the default clang include directory.  Same steps work with g++.
Comment 1 Darcy 2015-11-06 21:26 EST
Created attachment 1090820 [details]
Test case

Compile with clang++ -fopenmp main.cpp  - expected output to be a hello from each thread.
Comment 2 Darcy 2016-03-09 01:15:15 EST
With the release of LLVM 3.8, Clang now has in tree OpenMP: http://llvm.org/releases/3.8.0/tools/clang/docs/ReleaseNotes.html#openmp-support-in-clang

Are there plans to include this in F23?
Comment 3 Darcy 2016-03-09 18:32:50 EST
To try and move this a little higher up on the priority list, I wrote a poem called Please.

Up until now I've kept my peace
Politely waiting for you to release
Doth message to proclaim the maintainer is not dead
As at all costs I must use all my threads
That is the dream to you I implore
Except I sit here #pragma omp parallel wait for

Close the bug, another is done
Lest we forget cryptic compiler error fun
All and all g++ is sublime
Nevertheless in the repos it is Clang 3.8 I want to find
Good effort and my thanks to you, I hope to see it very soon!
Comment 4 Jan Včelák 2016-06-05 10:24:43 EDT
This is basically a new package request.

I like your poem. Hope you will like my new package request (bug #1342815).

*** This bug has been marked as a duplicate of bug 1342815 ***

Note You need to log in before you can comment on or make changes to this bug.