Bug 1276838 - SELinux is preventing hp-config_usb_p from 'create' accesses on the file password.cpython-34.pyc.139750676895760.
SELinux is preventing hp-config_usb_p from 'create' accesses on the file pass...
Status: CLOSED DUPLICATE of bug 1266903
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:ea6bb5191dc6dee025aa12bf2d7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-31 06:42 EDT by Francesco Frassinelli (frafra)
Modified: 2015-11-23 11:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 11:00:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francesco Frassinelli (frafra) 2015-10-31 06:42:09 EDT
Description of problem:
SELinux is preventing hp-config_usb_p from 'create' accesses on the file password.cpython-34.pyc.139750676895760.

*****  Plugin catchall_labels (83.8 confidence) suggests   *******************

If you want to allow hp-config_usb_p to have create access on the password.cpython-34.pyc.139750676895760 file
Then e' necessario modificare l'etichetta su password.cpython-34.pyc.139750676895760
Do
# semanage fcontext -a -t TIPO_FILE 'password.cpython-34.pyc.139750676895760'
dove TIPO_FILE è uno dei seguenti: cupsd_interface_t, cupsd_lock_t, cupsd_log_t, cupsd_rw_etc_t, cupsd_tmp_t, cupsd_var_lib_t, cupsd_var_run_t, krb5_host_rcache_t, print_spool_t. 
Quindi eseguire: 
restorecon -v 'password.cpython-34.pyc.139750676895760'


*****  Plugin catchall (17.1 confidence) suggests   **************************

If si crede che hp-config_usb_p dovrebbe avere possibilità di accesso create sui password.cpython-34.pyc.139750676895760 file in modo predefinito.
Then si dovrebbe riportare il problema come bug.
E' possibile generare un modulo di politica locale per consentire questo accesso.
Do
consentire questo accesso per il momento eseguendo:
# grep hp-config_usb_p /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:usr_t:s0
Target Objects                password.cpython-34.pyc.139750676895760 [ file ]
Source                        hp-config_usb_p
Source Path                   hp-config_usb_p
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-300.fc23.x86_64 #1 SMP Mon
                              Oct 5 15:42:54 UTC 2015 x86_64 x86_64
Alert Count                   52
First Seen                    2015-10-30 14:10:17 CET
Last Seen                     2015-10-30 14:20:59 CET
Local ID                      d3665b50-8481-4f2f-8ffb-a2c9cdba53c4

Raw Audit Messages
type=AVC msg=audit(1446211259.675:678): avc:  denied  { create } for  pid=6335 comm="hp-config_usb_p" name="password.cpython-34.pyc.139750676895760" scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:usr_t:s0 tclass=file permissive=0


Hash: hp-config_usb_p,cupsd_t,usr_t,file,create

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.3-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 1013073
Comment 1 Martín Cigorraga 2015-11-09 20:57:43 EST
Description of problem:
Unplugged the pendrive

Version-Release number of selected component:
selinux-policy-3.13.1-153.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64
type:           libreport
Comment 2 Jiri Popelka 2015-11-23 11:00:12 EST
Probably duplicate of bug #1266903

*** This bug has been marked as a duplicate of bug 1266903 ***

Note You need to log in before you can comment on or make changes to this bug.