Bug 1276843 - Keepass 2.30 unable to display icons for certain entry types
Keepass 2.30 unable to display icons for certain entry types
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: keepass (Show other bugs)
23
i386 Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Oliver
Fedora Extras Quality Assurance
https://sourceforge.net/p/keepass/bug...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-31 07:04 EDT by Peter Oliver
Modified: 2015-12-02 18:50 EST (History)
2 users (show)

See Also:
Fixed In Version: keepass-2.30-4.fc23 keepass-2.30-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 16:51:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Oliver 2015-10-31 07:04:26 EDT
Four of the entry icons are not displayed.  The following messages are displayed on the terminal:

libpng error: invalid after png_start_read_image or png_read_update_info
libpng error: invalid after png_start_read_image or png_read_update_info
libpng error: invalid after png_start_read_image or png_read_update_info
libpng error: invalid after png_start_read_image or png_read_update_info

Looks like a regression of https://bugs.gentoo.org/show_bug.cgi?id=472764.
Comment 1 Peter Oliver 2015-10-31 14:42:35 EDT
Reported upstream at https://sourceforge.net/p/keepass/bugs/1443/.
Comment 2 Fedora Update System 2015-11-22 16:41:14 EST
keepass-2.30-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ce3bdbec7b
Comment 3 Fedora Update System 2015-11-22 16:49:57 EST
keepass-2.30-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-703a7aad00
Comment 4 Fedora Update System 2015-11-22 16:51:45 EST
keepass-2.30-2.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-aceb4313a9
Comment 5 Fedora Update System 2015-11-23 19:23:49 EST
keepass-2.30-2.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update keepass'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-aceb4313a9
Comment 6 Fedora Update System 2015-11-23 19:54:37 EST
keepass-2.30-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update keepass'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-703a7aad00
Comment 7 Fedora Update System 2015-11-23 21:23:55 EST
keepass-2.30-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update keepass'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ce3bdbec7b
Comment 8 Fedora Update System 2015-12-02 16:51:01 EST
keepass-2.30-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-12-02 18:50:15 EST
keepass-2.30-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.