Bug 1276850 - /var/lib/dnf/yumdb/*/*/checksum_data
/var/lib/dnf/yumdb/*/*/checksum_data
Status: CLOSED DUPLICATE of bug 1167239
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-31 08:10 EDT by Sami Farin
Modified: 2015-11-02 10:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 10:39:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sami Farin 2015-10-31 08:10:52 EDT
Description of problem:
When doing e.g. "dnf upgrade", instead of reading one line of every checksum_data file in there, it could use a database instead.

# find /var/lib/dnf/yumdb -type f -name checksum_data|wc -l
19196

Version-Release number of selected component (if applicable):
1.1.3-1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
waste 10 minutes waiting (if no SSD) for dnf to read 19196 files

Expected results:
waste 0.1 seconds for a similar operation if using database

Additional info:
Comment 1 Honza Silhan 2015-11-02 10:39:13 EST

*** This bug has been marked as a duplicate of bug 1167239 ***

Note You need to log in before you can comment on or make changes to this bug.