Bug 1276856 - __svc_vc_dodestroy: close memory leak
__svc_vc_dodestroy: close memory leak
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libtirpc (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
xzhou
:
Depends On:
Blocks: 1268411
  Show dependency treegraph
 
Reported: 2015-10-31 10:32 EDT by Steve Dickson
Modified: 2016-05-10 16:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: libtirpc-0.2.1-11.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:07:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2015-10-31 10:32:04 EDT
Description of problem:

commit 229455848ab703603787b1881595e4bd05bc40c4
Author: Steve Dickson <steved@redhat.com>
Date:   Mon Jun 22 12:41:18 2015 -0400

    __svc_vc_dodestroy: close memory leak
    
    A rendezvouser socket is defined by a
    xp_port value of (u_short)-1 which does
    not work because xp_port is overwritten
    by svc_com_create() and 65535 is a valid
    port value.
    
    To ensure actual connections get freed
    properly in __svc_vc_dodestroy(), compare
    the xp_recv value to rendezvous_request.
    
    Reported-by: Michael Theall <mtheall@us.ibm.com>
    Signed-off-by: Steve Dickson <steved@redhat.com>
Comment 5 errata-xmlrpc 2016-05-10 16:07:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0769.html

Note You need to log in before you can comment on or make changes to this bug.