Bug 1276921 - [abrt] dnf: history.py:825:_commit:sqlite3.OperationalError: database is locked
[abrt] dnf: history.py:825:_commit:sqlite3.OperationalError: database is locked
Status: CLOSED DUPLICATE of bug 1167239
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:587268b1a413ec9b9b949329b45...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-01 05:40 EST by Christian Stadelmann
Modified: 2015-11-02 10:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 10:50:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (1.56 MB, text/plain)
2015-11-01 05:40 EST, Christian Stadelmann
no flags Details
File: backtrace (1.32 KB, text/plain)
2015-11-01 05:40 EST, Christian Stadelmann
no flags Details
File: dnf-makecache.log (7.57 KB, text/plain)
2015-11-01 05:40 EST, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-11-01 05:40:18 EST
Description of problem:
I ran dnf on cli as root while yumex-dnf was still running as admin user.

Version-Release number of selected component:
dnf-1.1.3-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /usr/bin/dnf remove cups cups-filters
executable:     /usr/bin/dnf
kernel:         4.2.3-300.fc23.x86_64
runlevel:       N 5
type:           Python3

Truncated backtrace:
history.py:825:_commit:sqlite3.OperationalError: database is locked

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 144, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 173, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 228, in do_transaction
    super(BaseCli, self).do_transaction(display)
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 604, in do_transaction
    self._run_transaction(cb=cb)
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 662, in _run_transaction
    [], [], cmdline)
  File "/usr/lib/python3.4/site-packages/dnf/yum/history.py", line 1019, in beg
    self._commit()
  File "/usr/lib/python3.4/site-packages/dnf/yum/history.py", line 825, in _commit
    return self._conn.commit()
sqlite3.OperationalError: database is locked

Local variables in innermost frame:
self: <dnf.yum.history.YumHistory object at 0x7f9cfc17f748>
Comment 1 Christian Stadelmann 2015-11-01 05:40:30 EST
Created attachment 1088338 [details]
File: _var_log_dnf.log
Comment 2 Christian Stadelmann 2015-11-01 05:40:32 EST
Created attachment 1088339 [details]
File: backtrace
Comment 3 Christian Stadelmann 2015-11-01 05:40:34 EST
Created attachment 1088340 [details]
File: dnf-makecache.log
Comment 4 Honza Silhan 2015-11-02 10:50:13 EST

*** This bug has been marked as a duplicate of bug 1167239 ***

Note You need to log in before you can comment on or make changes to this bug.