Bug 1276987 - missing snippets/packagekit-cached-metadata.ks file
missing snippets/packagekit-cached-metadata.ks file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-01 21:00 EST by Parag Nemade
Modified: 2015-11-15 19:22 EST (History)
6 users (show)

See Also:
Fixed In Version: spin-kickstarts-0.23.6-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-15 19:22:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2015-11-01 21:00:52 EST
Description of problem:

I think spin-kickstarts's subpackage fedora-kickstarts is missing file to be packaged snippets/packagekit-cached-metadata.ks

I am getting error for missing this file when I attempt to build livecd using fedora-live-workstations.ks

Version-Release number of selected component (if applicable):
fedora-kickstarts-0.23.6-2.fc23.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Bruno Wolff III 2015-11-02 14:44:06 EST
It looks like snippets wasn't originally for stuff that was to be included so we didn't miss not including them. templates and tools should get put into a subpackage as well for completeness. If snippets are to be includable, they'll need to be required. I'll take a look at this and see what makes sense.
Comment 2 Bruno Wolff III 2015-11-02 16:02:54 EST
In this specific case I am note sure we should be using snippets/packagekit-cached-metadata.ks. Thus seems like a hack and it isn't obvious to me if that data is easily rebuildable later. (For possible GPL need.)
Comment 3 Bruno Wolff III 2015-11-02 17:09:06 EST
Probably the best short term fix is to move the include file out of snippets into the main level.
We probably want a misc sub package that has the tools and snippets folders. The templates folder stuff should probably be moved to snippets.
In the longer run the packagekit-cached-metadata.ks feature should probably be dropped. KDE dropped it because it will be out of date by release. Live images probably aren't going to make much use of it. It makes the images bigger. (Though for now it's just workstation.)
I notice that workstation's post does another bad thing, by removing install files rather than not having them installed.
Comment 4 Kalev Lember 2015-11-03 08:36:17 EST
We need this on Workstation to make initial gnome-software startup quick. See https://blogs.gnome.org/hughsie/2014/08/29/putting-packagekit-metadata-on-the-fedora-livecd/ for details.

As for moving it out of snippets/ -- sure, fine with me. Although I wonder if we should instead clean up the unused include files in there, looks like a whole lot of unneeded stuff, and then ship the whole directory.


> I notice that workstation's post does another bad thing, by removing install files rather than not having them installed.

I don't understand, can you elaborate what you mean?
Comment 5 Kalev Lember 2015-11-06 03:30:48 EST
I pushed a few fixes to try to get things working again. Bruno, do the changes look good to you?

For F23, I pushed a fix to spin-kickstarts packaging to install the missing file, so that we can keep the changes minimal there and also so that we could keep using the GA tarball:
http://pkgs.fedoraproject.org/cgit/spin-kickstarts.git/commit/?h=f23&id=f253a18f20d0006678ef54971882a756000cf063

For master, I went with a bit more invasive changes that require a respin of the tarball:
https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=dff74da0db53b2def82666cb324297a902a457c4
https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=add7504fce6baecead6769feedf242c950dcbedd
Comment 6 Fedora Update System 2015-11-06 03:45:37 EST
spin-kickstarts-0.23.6-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-a558c54a4c
Comment 7 Fedora Update System 2015-11-08 08:24:57 EST
spin-kickstarts-0.23.6-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update spin-kickstarts'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-a558c54a4c
Comment 8 Fedora Update System 2015-11-15 19:22:33 EST
spin-kickstarts-0.23.6-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.