This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 12770 - ifup fails to finish (return command prompt)
ifup fails to finish (return command prompt)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-20 21:18 EDT by Stephen Torri
Modified: 2014-03-16 22:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-20 21:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Torri 2000-06-20 21:18:58 EDT
Using Redhat 6.2 with initscripts 5.00-1 I have found that ifup fails to
return the command prompt after executing. I run /sbin/ifup ppp0 and it
dails into my ISP, logins in but I need to go to another virtual terminal
to start my masquerading scripts. The system initially had 6.0 and then was
upgraded to 6.2. The system was dialing into the ISP fine and starting up
the firewall scripts from within /etc/ppp/ifup-ppp0. Now it does not do
that. 

The bug is very repeatable. I can run whatever tests you feel it is
necessary to either determine this is a bug or not.
Comment 1 Bill Nottingham 2000-06-21 16:51:56 EDT
This is actually by design; it will exit when the ppp connection exits.
Comment 2 Bryan Reece 2000-07-30 15:46:35 EDT
RH 6.2 `ifup ppp0' returns after the connection is up and able to pass traffic
(at least in my installation with initscripts-5.00-1).

I am able to add a masquerading rule once at boot time and have it work for all
subsequent PPP connections; could this work for you?

Note You need to log in before you can comment on or make changes to this bug.