Bug 1277018 - No flash message displayed for terminate stack instance when navigated through stack summary page
No flash message displayed for terminate stack instance when navigated throug...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.6
Assigned To: Robin Knaur
Aziza Karol
ui:stack:power:flash_msg
: ZStream
Depends On:
Blocks: 1289333
  Show dependency treegraph
 
Reported: 2015-11-02 00:12 EST by Aziza Karol
Modified: 2017-08-21 09:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289333 (view as bug list)
Environment:
Last Closed: 2017-08-21 09:02:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
terminate stack instance (69.41 KB, image/png)
2015-11-02 00:12 EST, Aziza Karol
no flags Details
error in terminate stack instance (68.28 KB, image/png)
2016-01-19 02:31 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-11-02 00:12:31 EST
Created attachment 1088461 [details]
terminate stack instance

Description of problem:



Version-Release number of selected component (if applicable):
5.5.0.8

How reproducible:
100%

Steps to Reproduce:
1.Navigate to cloud->stacks->select a stack
2.click on the instance in relationship section of stack summary page
3.select the instance and from Power click on "Terminate"

Actual results:
No flash message displayed when stack instance is terminated. see attached screenshot

Expected results:


Additional info:
Comment 4 CFME Bot 2015-11-12 18:45:16 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/45d75ddc7509a9b0f081a096cc7967d8b2a33392

commit 45d75ddc7509a9b0f081a096cc7967d8b2a33392
Author:     Robin Knaur <rknaur@redhat.com>
AuthorDate: Wed Nov 11 14:21:49 2015 +0100
Commit:     Robin Knaur <rknaur@redhat.com>
CommitDate: Wed Nov 11 14:35:57 2015 +0100

    Terminate Cloud-Stacks-instance fix
    https://bugzilla.redhat.com/show_bug.cgi?id=1277018

 app/controllers/application_controller/ci_processing.rb | 1 +
 app/controllers/ems_common.rb                           | 2 --
 app/controllers/flavor_controller.rb                    | 2 --
 app/controllers/security_group_controller.rb            | 2 --
 4 files changed, 1 insertion(+), 6 deletions(-)
Comment 7 CFME Bot 2015-12-07 17:34:40 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=15d68c2f5f9c5801501c539c83e8754394c90cc3

commit 15d68c2f5f9c5801501c539c83e8754394c90cc3
Merge: 4fc885f a8ce4f1
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Dec 7 17:28:50 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Dec 7 17:28:50 2015 -0500

    Merge branch 'bz-1277018' into '5.5.z'
    
    Terminate Cloud-Stacks-instance fix
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1277018
    clean cherry-pick from https://github.com/ManageIQ/manageiq/commit/45d75ddc7509a9b0f081a096cc7967d8b2a33392
    
    See merge request !496

 app/controllers/application_controller/ci_processing.rb | 1 +
 app/controllers/ems_common.rb                           | 2 --
 app/controllers/flavor_controller.rb                    | 2 --
 app/controllers/security_group_controller.rb            | 2 --
 4 files changed, 1 insertion(+), 6 deletions(-)
Comment 8 CFME Bot 2015-12-07 17:34:45 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a8ce4f172cc8ed8eb797070f44a7eae701eee2d5

commit a8ce4f172cc8ed8eb797070f44a7eae701eee2d5
Author:     Robin Knaur <rknaur@redhat.com>
AuthorDate: Wed Nov 11 14:21:49 2015 +0100
Commit:     Robin Knaur <rknaur@redhat.com>
CommitDate: Wed Nov 25 14:03:44 2015 +0100

    Terminate Cloud-Stacks-instance fix
    https://bugzilla.redhat.com/show_bug.cgi?id=1277018

 app/controllers/application_controller/ci_processing.rb | 1 +
 app/controllers/ems_common.rb                           | 2 --
 app/controllers/flavor_controller.rb                    | 2 --
 app/controllers/security_group_controller.rb            | 2 --
 4 files changed, 1 insertion(+), 6 deletions(-)
Comment 10 Aziza Karol 2016-01-19 02:29:01 EST
"Error during 'vm_destroy': Unknown task, vm_destroy" is displayed on screen for terminate stack instance.see attached screenshot.

Version: 5.5.2.1.20160114044944_395c086
Comment 11 Aziza Karol 2016-01-19 02:31 EST
Created attachment 1116068 [details]
error in terminate stack instance
Comment 13 Chris Pelland 2017-08-21 09:02:37 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.