Bug 1277024 - BSD Smoke fails with _IOS_SAMP_DIR undeclared
BSD Smoke fails with _IOS_SAMP_DIR undeclared
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: io-stats (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Atin Mukherjee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 00:36 EST by Atin Mukherjee
Modified: 2016-06-16 09:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:42:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2015-11-02 00:36:30 EST
Description of problem:

Commit d3e496cb has introduced a constant _IOS_SAMP_DIR which was defined only for linux because of which in BSD smokes fail with undeclared _IOS_SAMP_DIR error.

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-11-02 00:37:18 EST
REVIEW: http://review.gluster.org/12484 (io-stats: fix BSD build failure) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Vijay Bellur 2015-11-02 04:47:55 EST
REVIEW: http://review.gluster.org/12484 (io-stats: fix BSD build failure) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 3 Vijay Bellur 2015-11-02 06:45:02 EST
REVIEW: http://review.gluster.org/12484 (io-stats: fix BSD build failure) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 4 Vijay Bellur 2015-11-02 13:21:59 EST
COMMIT: http://review.gluster.org/12484 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit af8b450df8dca2b07bcfc6c32f17bc678697e9f2
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Mon Nov 2 11:03:26 2015 +0530

    io-stats: fix BSD build failure
    
    Change-Id: Ieb372cb686d32a09c6df31ec849f1b3c52e0e1cd
    BUG: 1277024
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/12484
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:42:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.