Bug 1277028 - SMB: share entry from smb.conf is not removed after setting user.cifs and user.smb to disable.
SMB: share entry from smb.conf is not removed after setting user.cifs and use...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: RHGS 3.1.2
Assigned To: Raghavendra Talur
surabhi
: ZStream
Depends On:
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-11-02 01:02 EST by surabhi
Modified: 2016-03-01 00:49 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 00:49:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description surabhi 2015-11-02 01:02:49 EST
Description of problem:

Setting user.smb and user.cifs to disable doesn't remove the samba share from smb.conf.

when volume is stopped and started then only the share goes off from smb.conf.


Version-Release number of selected component (if applicable):
rpm -qa|grep gluster
glusterfs-libs-3.7.5-5.el7rhgs.x86_64
glusterfs-fuse-3.7.5-5.el7rhgs.x86_64
glusterfs-3.7.5-5.el7rhgs.x86_64
glusterfs-server-3.7.5-5.el7rhgs.x86_64
glusterfs-client-xlators-3.7.5-5.el7rhgs.x86_64
glusterfs-cli-3.7.5-5.el7rhgs.x86_64
glusterfs-api-3.7.5-5.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1.create a volume
2.Start the volume
3.Set the user.cifs and user.smb to disable
4.Check the output from testparm and check smb.conf entry
5.Share entry for the volume should be removed.


Actual results:
share is still present in smb.conf and is ready for access.

Expected results:
share entry should be removed and the share should not be ready for access if user.cifs and user.smb is disabled.

Additional info:
Comment 4 surabhi 2015-11-26 05:22:22 EST
Verified with following steps :

1.created a volume
2.Started the volume
3.Set the user.cifs and user.smb to disable
4.Check the output from testparm and check smb.conf entry

Expected result:
********************
With any of the options user.smb or user.cifs being set to disable should remove the entry from smb.conf and testparm should not show the share entry.

Actual result:
***************
With user.cifs set to disable , share entry is removed from smb.conf
With user.smb set to disable , share entry is removed from smb.conf

Marking the BZ verified using following build:

glusterfs-3.7.5-7.el7rhgs.x86_64
glusterfs-api-3.7.5-7.el7rhgs.x86_64
glusterfs-server-3.7.5-7.el7rhgs.x86_64
glusterfs-rdma-3.7.5-7.el7rhgs.x86_64
glusterfs-fuse-3.7.5-7.el7rhgs.x86_64
glusterfs-geo-replication-3.7.5-7.el7rhgs.x86_64
samba-vfs-glusterfs-4.2.4-6.el7rhgs.x86_64
glusterfs-libs-3.7.5-7.el7rhgs.x86_64
glusterfs-client-xlators-3.7.5-7.el7rhgs.x86_64
glusterfs-cli-3.7.5-7.el7rhgs.x86_64
Comment 5 Raghavendra Talur 2015-12-09 08:45:34 EST
This does not require doc text as the bug was introduced and fixed within the dev cycle and not exposed to customer/user.
Comment 7 errata-xmlrpc 2016-03-01 00:49:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.