Bug 1277029 - Steps for creating a PV and PVS not mentioned while having a registry use a persistent storage like NFS
Steps for creating a PV and PVS not mentioned while having a registry use a p...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
urgent Severity medium
: ---
: ---
Assigned To: brice
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 01:07 EST by Miheer Salunke
Modified: 2017-03-08 13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-13 19:43:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miheer Salunke 2015-11-02 01:07:13 EST
Document URL: https://docs.openshift.com/enterprise/3.0/install_config/install/docker_registry.html#storage-for-the-registry

Section Number and Name: Storage for the Registry

Describe the issue: 

https://docs.openshift.com/enterprise/3.0/install_config/install/docker_registry.html#storage-for-the-registry

The preceding paragraph to the command([1] : $ oc volume deploymentconfigs/docker-registry \ --add --overwrite --name=registry-storage --mount-path=/registry \ --source='{"nfs": { "server": "<fqdn>", "path": "/path/to/export"}}') says:

---
For production use, you should attach a remote volume or use persistent storage using PersistentVolume and PersistentVolumeClaim objects for storage for the registry. For example, to attach an existing NFS volume to the registry once it has been defined:
---

But then the command does not show using a PV/PVC. 


Suggestions for improvement: 
You need to mention steps for pv and pvc.
https://github.com/openshift/training/blob/master/07-Registry-and-Storage.md

Additional information:
Comment 2 brice 2015-11-30 00:45:12 EST
Miheer, I have created a PR for this BZ:

https://github.com/openshift/openshift-docs/pull/1273

In your opinion, does this PR satisfy this BZ? Thanks.
Comment 3 Alex Dellapenta 2015-11-30 12:04:28 EST
I believe the issue is mainly with the "oc volume" command using --source (a JSON string) instead of --claim-name (a PVC). See:

https://github.com/openshift/training/blob/master/07-Registry-and-Storage.md#attach-the-volume-to-the-registry

oc volume usage: 
https://docs.openshift.com/enterprise/latest/dev_guide/volumes.html

Discusses creating PVCs: 
https://docs.openshift.com/enterprise/latest/dev_guide/persistent_volumes.html
Comment 4 brice 2015-12-01 23:55:17 EST
Alex, ok. I think I get it. 

Miheer, I've added an example for adding pvcs as well:

https://github.com/bfallonf/openshift-docs/blob/BZ1277029/install_config/install/docker_registry.adoc#storage-for-the-registry

Miheer, is this closer to what you asked for?
Comment 5 Miheer Salunke 2015-12-02 02:06:55 EST
Hi Brice,

Yes it looks good.

Thanks and regards,
Miheer Salunke
Comment 6 brice 2015-12-03 00:11:31 EST
Miheer,

Thanks for that. PR is onto peer review.

B
Comment 7 openshift-github-bot 2015-12-06 20:00:30 EST
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/f281a5afa0096d50b57ea12458d0d20e6c1b022e
Merge pull request #1273 from bfallonf/BZ1277029

[peer review] Bug 1277029: edit link to storage options

Note You need to log in before you can comment on or make changes to this bug.