Bug 1277048 - Couldn't install openshift-ansible-inventory package
Couldn't install openshift-ansible-inventory package
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Troy Dawson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 03:00 EST by Gaoyun Pei
Modified: 2016-07-03 20:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 10:42:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2015-11-02 03:00:35 EST
Description of problem:
Failed to install openshift-ansible-bin or openshift-ansible-inventory due to lacking of python-boto and python-libcloud dependencies.
Couldn't find these two packages in latest openshift puddle or rhel-7.2 repo

Version-Release number of selected component (if applicable):
openshift-ansible-inventory-3.0.6-1.git.1.e0fd136.el7aos.noarch

How reproducible:
Always

Steps to Reproduce:
1. [root@openshift-v3 ~]# yum install openshift-ansible-inventory
Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package openshift-ansible-inventory.noarch 0:3.0.6-1.git.1.e0fd136.el7aos will be installed
--> Processing Dependency: python-libcloud >= 0.13 for package: openshift-ansible-inventory-3.0.6-1.git.1.e0fd136.el7aos.noarch
--> Processing Dependency: python-boto for package: openshift-ansible-inventory-3.0.6-1.git.1.e0fd136.el7aos.noarch
--> Finished Dependency Resolution
Error: Package: openshift-ansible-inventory-3.0.6-1.git.1.e0fd136.el7aos.noarch (ose-v3)
           Requires: python-boto
Error: Package: openshift-ansible-inventory-3.0.6-1.git.1.e0fd136.el7aos.noarch (ose-v3)
           Requires: python-libcloud >= 0.13
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Actual results:

Expected results:
Should install openshift-ansible-inventory without error.

Additional info:
Comment 1 Brenton Leanhardt 2015-11-02 11:04:52 EST
I think this package is primarily something that Ops needs.  I'm lowering the severity since we won't ship it in 3.1.  I'm going to remove it from the current puddle.

Troy, I'm passing this your way since it sounds similar to what Jason mentioned at scrum.  We may need additional sub packages to separate what is needed by Ops and what is needed in the product.
Comment 2 Troy Dawson 2015-11-06 10:12:08 EST
openshift-ansible has been updated so that openshift-ansible-inventory can install without the packages not in RHEL.

In addition both openshift-ansible-inventory and openshift-ansible-bin have been removed from the puddle because they are only needed for OpenShift Online, not for Atomic OpenShift Enterprise.

I believe this bug is fixed.
Comment 3 Gaoyun Pei 2015-11-08 21:53:08 EST
Move this to VERIFIED according to Comment 2, thanks!

Note You need to log in before you can comment on or make changes to this bug.