Bug 1277054 - peer probe using IPv6 not working
peer probe using IPv6 not working
Status: NEW
Product: GlusterFS
Classification: Community
Component: transport (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Atin Mukherjee
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 03:40 EST by Bishoy Mikhael
Modified: 2016-06-05 19:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bishoy Mikhael 2015-11-02 03:40:05 EST
Description of problem:


Version-Release number of selected component (if applicable):
3.7.x


How reproducible:
Always

Steps to Reproduce:
1. peer probe using IPv6 address


Actual results:
peer probe: failed: Probe returned with Transport endpoint is not connected

Expected results:
peer probe: success.

Additional info:
When you try to peer probe using IPv6 address, it fails.

The logs show the following error:

E [MSGID: 101075] [common-utils.c:306:gf_resolve_ip6] 0-resolver: getaddrinfo failed (Name or service not known)
E [name.c:247:af_inet_client_get_remote_sockaddr] 0-management: DNS resolution failed on host xxxxxxxxxxxxx

Note You need to log in before you can comment on or make changes to this bug.