Bug 1277069 - Memory penalty always work on hosts without engine vm
Memory penalty always work on hosts without engine vm
Status: CLOSED DUPLICATE of bug 1268892
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: Agent (Show other bugs)
1.3.1
All Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Martin Sivák
Ilanit Stein
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 04:09 EST by Artyom
Modified: 2015-11-02 05:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 05:13:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Artyom 2015-11-02 04:09:43 EST
Description of problem:
Memory penalty always work on hosts without engine vm

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-1.3.1-1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted engine on two hosts
2. Run hosted-engine --vm-status
3.

Actual results:
Host with vm have score 3400, host without vm have score 3000

Expected results:
Both hosts have score 3400

Additional info:
Problem in:
@property
def min_memory_threshold(self):
    return int(self._config.get(config.VM, config.MEM_SIZE))
it return tuple (4096, ) and not integer
Comment 1 Martin Sivák 2015-11-02 05:13:08 EST

*** This bug has been marked as a duplicate of bug 1268892 ***

Note You need to log in before you can comment on or make changes to this bug.