Bug 1277084 - RemoteBox-1.9-3.fc24 FTBFS: appdata-validate: command not found
RemoteBox-1.9-3.fc24 FTBFS: appdata-validate: command not found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: RemoteBox (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jitka Plesnikova
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 04:53 EST by Petr Pisar
Modified: 2015-11-05 03:42 EST (History)
2 users (show)

See Also:
Fixed In Version: RemoteBox-1.9-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 03:42:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-11-02 04:53:01 EST
RemoteBox-1.9-3.fc24 fails to build in F24 because tests fail:

Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.2uWCh8
+ umask 022
+ cd /builddir/build/BUILD
+ cd RemoteBox-1.9
+ appdata-validate --nonet /builddir/build/BUILDROOT/RemoteBox-1.9-3.fc24.noarch/usr/share/appdata/remotebox.appdata.xml
/var/tmp/rpm-tmp.2uWCh8: line 31: appdata-validate: command not found

Difference between working and failing build root:

        libappstream-glib 	0.5.1-2.fc24 	> 	0.5.2-1.fc24
	libgcab1 		> 	0.6-4.fc24
	krb5-libs 	1.14-4.fc24 	> 	1.14-6.fc24
	kernel-headers 	4.3.0-0.rc7.git0.1.... 	> 	4.3.0-0.rc7.git1.1....
	perl-Unicode-Normalize 	1.21-1.fc24 	> 	1.23-1.fc24

See libappstream-glib changelog: "Remove the long-obsolete appdata-validate tool."
Comment 1 Jitka Plesnikova 2015-11-04 04:02:35 EST
The fix is easy just change

appdata-validate --nonet %{buildroot}%{_datadir}/appdata/remotebox.appdata.xml

to

appstream-util validate --nonet %{buildroot}%{_datadir}/appdata/remotebox.appdata.xml

in RemoteBox.spec

Note You need to log in before you can comment on or make changes to this bug.