This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 12771 - tmpwatch should not be enabled by default
tmpwatch should not be enabled by default
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-20 22:56 EDT by Fyodor
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-20 22:56:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fyodor 2000-06-20 22:56:14 EDT
By default, Redhat 6.2 seems to install tmpwatch in cron.daily, set to
delete any files that haven't changed in 10 days.  The installation did not
warn me about this, and I ended up losing many important files.  I think
Redhat should ask the user before putting such a destructive command into
cron.  Why not disable it by default and let the user add it if they really
want this functionality?  It is better to default to "safe" operation in my
humble opinion.  The risk of having it disabled by default (unwanted files
piling up) seems far less severe than the risk of default-enabled
(important files deleted before they can be filed out of /tmp ).

Yes, I realize /tmp isn't the best place for important files, but IMHO that
does not mean you should arbitrarily decide that they should be deleted
every 10 days without informing the user.
Comment 1 Preston Brown 2000-09-11 14:46:48 EDT
we have done this since Red Hat Linux 2.x.  I will inform the docs team that
this needs to be addressed in the documentation.

However, we will continue to ship with tmpwatch on.  /tmp is _not_ a good place
to store _anything_.

Note You need to log in before you can comment on or make changes to this bug.