Bug 1277109 - Add tool tips for Revert, Refresh, Undo, and Undo All in the IPA UI
Add tool tips for Revert, Refresh, Undo, and Undo All in the IPA UI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Varun Mylaraiah
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 06:46 EST by Aneta Šteflová Petrová
Modified: 2016-11-04 01:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:39:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ToolTips (41.56 KB, image/png)
2016-09-15 11:37 EDT, Varun Mylaraiah
no flags Details

  None (edit)
Description Aneta Šteflová Petrová 2015-11-02 06:46:38 EST
Description of problem:

The following buttons in the IPA UI sometimes do the same thing from users' perspective: Revert, Refresh, Undo, Undo All
Currently, no description is available to help the users understand what the buttons do and how they differ from each other.

Steps to Reproduce:
For example:
1. Go to Network Services > DNS > DNS Global Configuration and add a forwarder.
2. Click the four buttons - they will all do the same thing: remove the new forwarder

Expected results:
Adding tool tips with some information about the buttons' purpose would help prevent users' confusion. For example:

Refresh - Reload current settings from the server
Revert - Undo all unsaved changes
Undo - Undo this change
Undo all - ???

Additional info:
It might actually be helpful to remove some of the buttons completely. Too many undo/revert buttons can be somewhat confusing.
Comment 2 Petr Vobornik 2015-11-02 11:39:22 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5428
Comment 3 Petr Vobornik 2016-01-27 08:17:23 EST
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/d5674b1490939551a0040a4d88ebc6f9437e74d9
Comment 4 Mike McCune 2016-03-28 18:43:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Varun Mylaraiah 2016-09-15 11:37 EDT
Created attachment 1201298 [details]
ToolTips

Verified

ipa-server-4.4.0-10.el7.x86_64

Tool tips added.
Comment 8 errata-xmlrpc 2016-11-04 01:39:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.