Bug 127711 - upgrading to xorg-x11-6.7.0-5 regresses xorg.conf
upgrading to xorg-x11-6.7.0-5 regresses xorg.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-07-12 16:28 EDT by Robert Clark
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 13:29:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Clark 2004-07-12 16:28:21 EDT
Upgrading from 6.7.0-2 to 6.7.0-5 caused my xorg.conf file to be
over-written with a copy of my old XF86Config-4 file.

Before the upgrade, I had old XF86Config & XF86Config-4 files plus my
xorg.conf file. Afterward, the files appear to have been moved as follows:

xorg.conf    -> xorg.conf.CT6684
XF86Config   -> XF86Config.bz6688
XF86Config-4 -> XF86Config-4.sO6692 & xorg.conf

There were no XF86Config or XF86Config-4 files remaining, nor any
XF86Config.obsoleted or XF86Config-4.obsoleted files.

Looking at the preinstall script, the only issue I can see is

  if [ -r xorg.conf]; then

should be

  if [ -r xorg.conf ]; then

but I can't see how this could cause what I'm seeing.
Comment 1 Mike A. Harris 2004-07-15 01:11:18 EDT
Ok, definitely sounds like a bug.  I've queue'd this issue as
a MUSTFIX for the next update release.  Thanks for reporting.
Comment 2 Kristian Høgsberg 2004-09-13 13:29:17 EDT
The type you refer to is indeed the cause of the problem

    for configfile in XF86Config-4 XF86Config ; do
      if [ -r $configfile ]; then
          if [ -r xorg.conf]; then
              mv -f $configfile $configfile.obsoleted
          else
              mv -f $configfile xorg.conf
          fi
      fi
    done

Without the space between xorg.conf and ], the test for an already
existing xorg.conf always fails and xorg.conf is overwritten with
XF86Config-4 and XF86Config if they exist.


Note You need to log in before you can comment on or make changes to this bug.