Bug 1277115 - gnome-software doesn't write data to dnf's history database
gnome-software doesn't write data to dnf's history database
Status: CLOSED DUPLICATE of bug 1259865
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 07:14 EST by Christian Stadelmann
Modified: 2016-09-28 15:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-28 15:59:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-11-02 07:14:38 EST
Description of problem:
After using gnome-software you can not see your package transactions (installation, removal, update, …) in dnf's history database. This renders `dnf history` pretty unreliable and `dnf history userinstalled` can't be used any more to get a kickstart file.

Version-Release number of selected component (if applicable):
dnf-1.1.3-1.fc23.noarch
gnome-software-3.18.2-2.fc23.x86_64
Comment 1 Kalev Lember 2015-11-04 11:36:27 EST
AFAIK the plan here is to make both DNF and gnome-software use libhif and have libhif write to the shared database.
Comment 2 Georg Sauthoff 2015-11-21 15:38:48 EST
Similar story when a package was installed via /usr/libexec/pk-command-not-found (part of PackageKit-command-not-found) then it also isn't listed in the output of `dnf history userinstalled`.

(cf. #1284194)
Comment 3 Christian Stadelmann 2016-09-28 15:59:31 EDT

*** This bug has been marked as a duplicate of bug 1259865 ***

Note You need to log in before you can comment on or make changes to this bug.