Bug 1277120 - Message on installation: "No protocol specified"
Message on installation: "No protocol specified"
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: octave (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 07:19 EST by Christian Stadelmann
Modified: 2016-04-04 16:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 16:22:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-11-02 07:19:03 EST
Description of problem:
When installing octave (and when installing some octave-* packages) I get this message on CLI while dnf/rpm is installing these packages:

No protocol specified

/var/log/dnf.librepo.log, /var/log/dnf.rpm.log and /var/log/dnf.log don't contain this message so I don't know what really happens.

Version-Release number of selected component (if applicable):
octave-4.0.0-5.fc23.x86_64
Comment 1 Orion Poplawski 2015-11-02 12:56:55 EST
Hmm, seems to be X/DISPLAY related.  I can't reproduce.  What is DISPLAY set to?  Although nothing should be trying to access it...
Comment 2 Christian Stadelmann 2015-11-02 16:03:03 EST
I don't get why this should be display related. These messages occured while running dnf running rpm installing octave packages. This operation was running as root on a tty, thus no DISPLAY or X-Related environment variables were set. An installer must not rely on those being present.
Comment 3 Orion Poplawski 2015-11-06 22:35:19 EST
The "No protocol specified" message is generally related to X applications failing to connect to a display, but perhaps it's something else.  I have no idea what it could be, as it shouldn't be happening and I cannot reproduce it.  If you can reproduce it, I would like to see the strace file from something like:

strace -f -s 2048 -o /tmp/dnf.strace dnf install octave....
Comment 4 Christian Stadelmann 2015-12-02 15:15:51 EST
Hm, I tried several times and can't reproduce it.

Note You need to log in before you can comment on or make changes to this bug.