Bug 1277137 - ovirt-ha-agent stopped after upgrade from 3.5 to 3.6
ovirt-ha-agent stopped after upgrade from 3.5 to 3.6
Status: CLOSED DUPLICATE of bug 1276740
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: Agent (Show other bugs)
1.3.1
All Linux
unspecified Severity urgent (vote)
: ---
: ---
Assigned To: Martin Sivák
Ilanit Stein
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 08:17 EST by Artyom
Modified: 2016-02-10 15:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 09:33:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
agent broker and vdsm logs from two hosts (1.84 MB, application/zip)
2015-11-02 08:17 EST, Artyom
no flags Details

  None (edit)
Description Artyom 2015-11-02 08:17:15 EST
Created attachment 1088568 [details]
agent broker and vdsm logs from two hosts

Description of problem:
ovirt-ha-agent stopped after upgrade from 3.5 to 3.6 with error message under agent.log
MainThread::ERROR::2015-11-02 11:38:30,675::agent::205::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Error: 'Failed to start monitor <type 'type'>, options {'hostname': 'alma05.qa.lab.tlv.redhat.com'}: Request failed: <class 'ConfigParser.MissingSectionHeaderError'>' - trying to restart agent


Version-Release number of selected component (if applicable):
From:

Hosts(RHEL7.1) - ovirt-hosted-engine-setup-1.2.6.1-1.el7ev.noarch
                 ovirt-hosted-engine-ha-1.2.8-1.el7ev.noarch
                 vdsm-4.16.28-1.el7ev.x86_64
                 libvirt-1.2.8-16.el7_1.5.x86_64
                 
Engine(RHEL6.7) - rhevm-3.5.6.1-0.1.el6ev.noarch

To: 

Engine(RHEL6.7) - rhevm-3.6.0.2-0.1.el6.noarch

Hosts(RHEL7.2) - ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
                 ovirt-hosted-engine-ha-1.3.1-1.el7ev.noarch
                 vdsm-4.17.10-5.el7ev.noarch
                 libvirt-1.2.17-13.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted-engine on two hosts under 3.5
2. Set global maintenance
3. Upgrade engine to 3.6
4. Put host without engine vm to maintenance
4. Upgrade host without engine vm to 3.6
5. reboot host

Actual results:
with error message under agent.log
MainThread::ERROR::2015-11-02 11:38:30,675::agent::205::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Error: 'Failed to start monitor <type 'type'>, options {'hostname': 'alma05.qa.lab.tlv.redhat.com'}: Request failed: <class 'ConfigParser.MissingSectionHeaderError'>' - trying to restart agent


Expected results:
ovirt-ha-agent run without any errors and hosted-engine --vm-status show correct information

Additional info:
Storage NFS
Comment 1 Simone Tiraboschi 2015-11-02 09:33:24 EST

*** This bug has been marked as a duplicate of bug 1276740 ***

Note You need to log in before you can comment on or make changes to this bug.