Bug 1277140 - Weird handling of broken dependencies
Weird handling of broken dependencies
Status: CLOSED DUPLICATE of bug 1148627
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 08:27 EST by Vít Ondruch
Modified: 2015-11-02 10:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 10:57:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2015-11-02 08:27:04 EST
Description of problem:
Today, vagrant-libvirt build failed in Koschei [1] with message:

"package rubygem-fog-libvirt-0.0.2-2.fc24.noarch requires rubygem(ruby-libvirt) >= 0.5.0, but none of the providers can be installed"

This is weird, since nothing changed in these particular packages. So let me try this to reproduce.


$ sudo dnf --installroot /var/lib/mock/fedora-rawhide-x86_64/root/ --releasever 24 install vagrant-libvirt --setopt=tsflags=nocontexts 
local                                                                                                                                                                              2.2 MB/s |  40 MB     00:18    
Last metadata expiration check performed 0:00:32 ago on Mon Nov  2 14:13:58 2015.
Error: package vagrant-libvirt-0.0.32-1.fc24.noarch requires rubygem(fog-libvirt), but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)



Ok, so I can reproduce the error locally. Let's try to install rubygem(fog-libvirt):


$ sudo dnf --installroot /var/lib/mock/fedora-rawhide-x86_64/root/ --releasever 24 install 'rubygem(ruby-libvirt)' --setopt=tsflags=nocontexts 
local                                                                                                                                                                              4.6 MB/s |  40 MB     00:08    
Last metadata expiration check performed 0:00:00 ago on Mon Nov  2 12:55:57 2015.
Error: nothing provides libtirpc.so.1()(64bit) needed by rpcbind-0.2.3-0.2.fc23.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)


Ah, so the fog-libvirt is not installable by itself, but this time the message is completely different!

Let's try to install the package instead of virtual provide directly:



$ sudo dnf --installroot /var/lib/mock/fedora-rawhide-x86_64/root/ --releasever 24 install 'rubygem-ruby-libvirt' --setopt=tsflags=nocontexts 
fedora                                                                                                                                                                              73 MB/s |  44 MB     00:00    
local                                                                                                                                                                              5.1 MB/s |  40 MB     00:07    
Last metadata expiration check performed 0:00:04 ago on Mon Nov  2 14:24:38 2015.
Error: nothing provides libtirpc.so.1()(64bit) needed by nfs-utils-1:1.3.2-11.fc23.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)



Once more, completely different error!

To sum this up, I'd really appreciate, if the error message for vagrant-libvirt was not blaming wrong packages, since the problem is very likely caused by libtirpc soname bump. Also, I wonder what is actually difference between resolving virtual provide and the package name, since the error message should be the same for both cases IMO.

Version-Release number of selected component (if applicable):
$ rpm -q dnf
dnf-1.1.3-1.fc24.noarch

$ rpm -q libsolv
libsolv-0.6.14-2.fc24.x86_64



How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
package vagrant-libvirt-0.0.32-1.fc24.noarch requires rubygem(fog-libvirt), but none of the providers can be installed

Expected results:
package vagrant-libvirt-0.0.32-1.fc24.noarch can't be installed, because libtirpc-1.0.1-0.0.fc24 is incompatible with rpcbind-0.2.3-0.2.fc23.x86_64 and nfs-utils-1:1.3.2-11.fc23.x86_64

The best would be if there is the whole dependency chain reported.

Additional info:

[1] https://apps.fedoraproject.org/koschei/package/vagrant-libvirt
Comment 1 Honza Silhan 2015-11-02 10:57:40 EST

*** This bug has been marked as a duplicate of bug 1148627 ***

Note You need to log in before you can comment on or make changes to this bug.