Bug 1277165 - [Wayland] Minetest no pointer lock
Summary: [Wayland] Minetest no pointer lock
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wayland   
(Show other bugs)
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2015-11-02 14:35 UTC by srakitnican
Modified: 2016-10-27 17:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-27 17:31:45 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description srakitnican 2015-11-02 14:35:26 UTC
Description of problem: It is impossible to navigate character due to cross moving infinite amount of distance. When mouse cursor is in center of window cross is not moving anywhere, as soon as the cursor moves out of center cross starts to spin without stopping in the same direction cursor moved from center.


Version-Release number of selected component (if applicable):
minetest-0.4.12-4.fc23.x86_64


How reproducible: Always


Steps to Reproduce:
1. Start game and join/create new world
2. You should see cross moving infinitely (spinning around)

Actual results:


Expected results:


Additional info: https://imgrush.com/8GBH6QxmzVx1

Comment 1 Olivier Fourdan 2015-11-03 13:48:04 UTC
That would be a duplicate of bug 1242322

There is no relative/locking pointer confinement in Wayland *yet*, it's still under discussion/review upstream.

http://lists.freedesktop.org/archives/wayland-devel/2014-December/018653.html

and

http://lists.freedesktop.org/archives/wayland-devel/2015-October/024726.html

Comment 2 srakitnican 2016-10-27 17:31:45 UTC
Seems resolved with xorg-x11-server-Xwayland-1.19.0-0.3.20161026.fc25.x86_64


Note You need to log in before you can comment on or make changes to this bug.