Bug 1277168 - Backport caused breakage in heat keystone domain creation
Backport caused breakage in heat keystone domain creation
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: z3
: 7.0 (Kilo)
Assigned To: Ivan Chavero
nlevinki
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 09:38 EST by Jiri Stransky
Modified: 2015-12-21 12:11 EST (History)
6 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1.8-27.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 12:11:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Stransky 2015-11-02 09:38:16 EST
Creation of heat keystone domain broke in both undercloud and overcloud of OSP-d because of a backport done into OPM. We initially attempted to fix it by updating instack-undercloud and tripleo-heat-templates, but it turns out that the current upstream probably still contains a bug (dependencies there aren't set up properly in heat::keystone::domain class).

There are already 3 patches proposed upstream to solve this situation. However these patches aren't merged at the moment, so the level of confidence in them isn't very high yet, and historically we've hit trouble several times in the area of heat keystone domain creation. So we'd prefer to go the safer way and revert the patch which introduced the breakage into downstream OPM in the first place.

The symptoms are visible from the related OSP-d BZs:

https://bugzilla.redhat.com/show_bug.cgi?id=1274439
https://bugzilla.redhat.com/show_bug.cgi?id=1275812
Comment 4 nlevinki 2015-12-10 03:40:54 EST
rpm -qa | grep openstack-puppet-modules
openstack-puppet-modules-2015.1.8-31.el7ost.noarch

OSPD installation passed and both tickets that had the issues are verified.
The symptoms are visible from the related OSP-d BZs:

https://bugzilla.redhat.com/show_bug.cgi?id=1274439
https://bugzilla.redhat.com/show_bug.cgi?id=1275812
Comment 6 errata-xmlrpc 2015-12-21 12:11:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2677

Note You need to log in before you can comment on or make changes to this bug.