Bug 1277195 - Requesting un-retire of passenger packages for EL6
Requesting un-retire of passenger packages for EL6
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: passenger (Show other bugs)
el6
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 11:17 EST by kristiaan.bonjean
Modified: 2015-11-17 04:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 04:32:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kristiaan.bonjean 2015-11-02 11:17:51 EST
Description of problem:
Trying to reinstall my EL6-based server, where I use Apache+Passenger for hosting my Puppet master, I discovered the Passenger packages were retired from EPEL6.
As this worked before, to me this conflicts with https://fedoraproject.org/wiki/History_and_Philosophy_of_EPEL:
"Packages in EPEL should be supported for the full life cycle of the Enterprise Linux they are build against."
Could these packages be unretired?


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Start minimal EL6
2. Install https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
3. Perform 'yum install mod_passenger rubygem-passenger rubygem-passenger-native rubygem-passenger-native-libs


Actual results:
Setting up Install Process
No package mod_passenger available.
No package rubygem-passenger available.
No package rubygem-passenger-native available.
No package rubygem-passenger-native-libs available.
Error: Nothing to do


Expected results:
Requested packages getting installed as before.


Additional info:
Comment 1 Orion Poplawski 2015-11-02 11:23:30 EST
Well, we try, but being human and with limited time and resources, we fail sometimes.

2015-10-29: Retired because of broken deps:
unresolved dependencies for rubygem-passenger-3.0.21-11.el6.i686:
rubygem(fastthread) >= 0:1.0.1

So, we'd need someone willing to maintain (at least) rubygem-fastthread as well as passenger in EPEL6.  I'm no longer interested in it though, so it would need to be someone else.
Comment 2 kristiaan.bonjean 2015-11-17 04:32:00 EST
In the meanwhile, I've discovered the developers release RPM packages themselves nowadays, so it makes much more sense for me to use those instead of EPEL. Therefor I'm closing this bug report.

Thanks for your reply and your prior efforts maintaining these packages!

Note You need to log in before you can comment on or make changes to this bug.