Bug 1277209 - Double click on split table checkbox column shouldn't initiate item move
Double click on split table checkbox column shouldn't initiate item move
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: vszocs
Lukas Svaty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 11:59 EST by Martin Betak
Modified: 2016-07-05 03:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:50:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
ecohen: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48454 master MERGED webadmin,userportal: Fix SplitTable double-click on selection column 2016-01-12 07:21 EST

  None (edit)
Description Martin Betak 2015-11-02 11:59:36 EST
Description of problem:

When using the SplitTable component with double click item moving enabled, the item is moved even when the double click occurs in a "checkbox" column with the purpose to (un)check the checkbox. Many times this "double" click is accidental and results in the item being moved to another table which requires manual correction.

The double click handler should probably be only registered on non-checkbox columns and not entire table row. 


Version-Release number of selected component (if applicable): 
4.0.0


Steps to Reproduce:
1. Look at any widget implemented using split table with double click moving and checkbox column: e.g Add Host Device dialog (vm tab -> host device sub tab -> add device)
2. Double click on checkbox "accidentally".

Actual results:
The item is moved to the second table.

Expected results:
Item should not be moved.
Comment 2 Einav Cohen 2015-11-05 10:11:42 EST
related to https://gerrit.ovirt.org/#/c/43726/ / bug 1099760, I assume.
Comment 3 vszocs 2015-11-09 10:30:08 EST
(In reply to Einav Cohen from comment #2)
> related to https://gerrit.ovirt.org/#/c/43726/ / bug 1099760, I assume.

Correct.

The implementation uses GWT "cell preview" handler that applies to all table cells (columns).

The fix should be easy since CellPreviewEvent#getColumn exposes the index of the target column.
Comment 4 Lukas Svaty 2016-06-24 06:59:55 EDT
verified in ovirt-engine-webadmin-portal-4.0.0.4-0.1.el7ev.noarch
Comment 5 Sandro Bonazzola 2016-07-05 03:50:43 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.