Bug 1277219 - nologin is included in /etc/shells
nologin is included in /etc/shells
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: setup (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 12:23 EST by Marek Haicman
Modified: 2015-11-06 08:51 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-06 08:51:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Haicman 2015-11-02 12:23:21 EST
Description of problem:
/etc/shells contains /sbin/nologin and /usr/sbin/nologin . By including these, it is possible to switch to such user with 'su' command with login override. That behaviour is not intuitive result of setting nologin for a user.

Version-Release number of selected component (if applicable):
setup-2.8.71-6.el7

How reproducible:
reliably

Steps to Reproduce:
1. grep nologin /etc/shells


Actual results:
/sbin/nologin
/usr/sbin/nologin


Expected results:
No output
Comment 1 Ondrej Vasik 2015-11-02 15:16:06 EST
Thanks for information, however, you are not the first one reporting it. See e.g. https://bugzilla.redhat.com/show_bug.cgi?id=70414 , https://bugzilla.redhat.com/show_bug.cgi?id=230650.
Actually, /sbin/nologin was added as request by https://bugzilla.redhat.com/show_bug.cgi?id=53963 . I believe, without further discussion, this has to be closed not a bug. Feel free to discuss potential risk caused by this /etc/shells entry on fedora devel list and add a pointer to the mail thread into this bugzilla. Without further discussion, I will close this request NOTABUG.
Comment 2 Marek Haicman 2015-11-03 04:23:34 EST
Thanks Ondrej for the clarification, sorry for my weak search-fu. I agree we can close it for now.

I will just put here, for future reference, another bug related to this... https://bugzilla.redhat.com/show_bug.cgi?id=1218302
Comment 3 Ondrej Vasik 2015-11-06 08:51:33 EST
Ok, thanks for annother cross-component bugzilla reference. Closing NOTABUG for now.

Note You need to log in before you can comment on or make changes to this bug.