Bug 1277228 - package gdeploy doesn't list python-argparse as dependency
package gdeploy doesn't list python-argparse as dependency
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity medium
: ---
: RHGS 3.1.3
Assigned To: Sachidananda Urs
Anush Shetty
: ZStream
Depends On:
Blocks: 1299184
  Show dependency treegraph
 
Reported: 2015-11-02 13:01 EST by Martin Bukatovic
Modified: 2016-06-23 01:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: gdeploy-2.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:28:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Bukatovic 2015-11-02 13:01:01 EST
Description of problem
======================

On RHEL 6, gdeploy package is missing python-argparse dependency.

This is not necessary for RHEL 7 package, because argparse module
is included in python 2.7 stdlib.

Version-Release number of selected component (if applicable)
============================================================

gdeploy-1.0-12.el6rhs.noarch

How reproducible
================

100 %

Steps to Reproduce
==================

1. Check requirements of gdeploy package for RHEL 6 via `rpm -qR`

Actual results
==============

There is no python-argparse in the list of requirements:

~~~
# rpm -qR gdeploy
/usr/bin/python  
python(abi) = 2.6
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
~~~

Expected results
================

~~~
# rpm -qR gdeploy | grep python-argparse
python-argparse
~~~
Comment 1 Sachidananda Urs 2015-11-04 08:02:32 EST
Martin,

This was not listed because python-argparse is installed as part of RHS installation.

[root@rhs-1 gstatus]# yum list installed | grep python-argp
python-argparse.noarch              1.2.1-2.1.el6            @anaconda-InstallationRepo-201507260759.x86_64/3.1


Please correct me if I'm wrong.
Comment 6 Sachidananda Urs 2015-11-06 11:39:53 EST
Fixed in branch: https://github.com/gluster/gdeploy/tree/1.1
Comment 9 Anush Shetty 2016-04-11 01:24:51 EDT
Verified with gdeploy-2.0-2.el6rhs.noarch
Comment 11 errata-xmlrpc 2016-06-23 01:28:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1250

Note You need to log in before you can comment on or make changes to this bug.