Bug 1277262 - iscsi target broken with ms iscsi initiator in recent kernels
iscsi target broken with ms iscsi initiator in recent kernels
Status: CLOSED DUPLICATE of bug 1273252
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-11-02 15:27 EST by Torbjorn Jansson
Modified: 2015-11-02 15:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-11-02 15:36:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Torbjorn Jansson 2015-11-02 15:27:58 EST
Description of problem:
Upgraded my fedora 22 installation from kernel 4.0.4-303.fc22.x86_64 to 4.2.3-200.fc22.x86_64 and now iscsi target no longer works.

i have a windows computer that uses the microsoft iscsi initiator and this worked just fine on my 4.0.4 kernel but with 4.2.3 i get the following errors in dmesg:
Got unknown iSCSI OpCode: 0x43
Cannot recover from unknown opcode while ERL=0, closing iSCSI connection.
repeatedly when ms iscsi intiator tries to connect and then the connection fails resulting in unavailable isci devices.

after a bit of searching i found the following discussion that i think describes the issue very well:

looks like there is a kernel bug.

How reproducible:
setup targetcli on linux and use a windows computer as iscsi initiator.
with older kernels like 4.0.4 it works, but with newer 4.2.3 kernel initiator is unable to connect.

Actual results:
not possible to connect

Expected results:
connection should work as it did with older kernels.
Comment 1 Josh Boyer 2015-11-02 15:36:49 EST

*** This bug has been marked as a duplicate of bug 1273252 ***

Note You need to log in before you can comment on or make changes to this bug.