Bug 1277264 - kernel-install: line 95: syntax error near unexpected token `done'
kernel-install: line 95: syntax error near unexpected token `done'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
: Reopened
: 1277661 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 15:53 EST by poma
Modified: 2015-11-04 11:24 EST (History)
11 users (show)

See Also:
Fixed In Version: systemd-227-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 11:24:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description poma 2015-11-02 15:53:29 EST
Fix "syntax error near unexpected token `done'"

...
/bin/kernel-install: line 95: syntax error near unexpected token `done'
/bin/kernel-install: line 95: `        done'
warning: %posttrans(kernel-core-4.3.0-1.fc24.x86_64) scriptlet failed, exit status 2
Non-fatal POSTTRANS scriptlet failure in rpm package kernel-core-4.3.0-1.fc24.x86_64
/bin/kernel-install: line 95: syntax error near unexpected token `done'
/bin/kernel-install: line 95: `        done'
warning: %posttrans(kernel-debug-core-4.3.0-1.fc24.x86_64) scriptlet failed, exit status 2
Non-fatal POSTTRANS scriptlet failure in rpm package kernel-debug-core-4.3.0-1.fc24.x86_64
...

---
 kernel-install-grubby.patch | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel-install-grubby.patch b/kernel-install-grubby.patch
index 1326a59..3069db0 100644
--- a/kernel-install-grubby.patch
+++ b/kernel-install-grubby.patch
@@ -40,7 +40,7 @@ index 3ae1d77..5c1e4fc
 +            cp -a "$i" "/boot/.${KERNEL_IMAGE##*/}-${KERNEL_VERSION}.hmac"
 +            command -v restorecon &>/dev/null && \
 +                restorecon "/boot/.${KERNEL_IMAGE##*/}-${KERNEL_VERSION}.hmac"
-+        done
++        fi
 +    fi
 +
 +    [[ "$KERNEL_VERSION" == *\+* ]] && flavor=-"${KERNEL_VERSION##*+}"
-- 
2.6.2
Comment 1 Jan Synacek 2015-11-03 03:45:20 EST
What file have you actually patched? In what package? There is no such code in kernel-install in Rawhide.
Comment 2 poma 2015-11-03 08:48:19 EST
(In reply to Jan Synacek from comment #1)
> What file have you actually patched? In what package? There is no such code
> in kernel-install in Rawhide.

http://pkgs.fedoraproject.org/cgit/systemd.git/tree/kernel-install-grubby.patch#n43
Comment 3 Zbigniew Jędrzejewski-Szmek 2015-11-03 19:17:10 EST
*** Bug 1277661 has been marked as a duplicate of this bug. ***
Comment 4 poma 2015-11-04 11:16:32 EST
Information for package systemd
http://koji.fedoraproject.org/koji/packageinfo?packageID=10477

"Fixed In Version: 	systemd-227-3.fc24"

Where is this version?
Comment 5 poma 2015-11-04 11:22:10 EST
BTW mister Hoyer, why dont you fix this, it came with your commit
http://pkgs.fedoraproject.org/cgit/systemd.git/commit/?id=f6039fa
Comment 6 Zbigniew Jędrzejewski-Szmek 2015-11-04 11:24:58 EST
It seem that I didn't actually build the package. Building now.

Note You need to log in before you can comment on or make changes to this bug.