Bug 1277277 - Text changes to fusor-installer prompts
Text changes to fusor-installer prompts
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity low
: ga
: 1.0
Assigned To: Derek Whatley
Tasos Papaioannou
: Triaged
Depends On:
Blocks: rhci-sprint-11 rhci-sprint-16 qci-sprint-17
  Show dependency treegraph
 
Reported: 2015-11-02 17:05 EST by Matt Reid
Modified: 2016-09-13 12:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:22:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2015-11-02 17:05:36 EST
Description of problem:
fusor-installer could use some revisions to the strings it shows. Right now we have:

Please select NIC on which you want provisioning enabled:
1. eth0
2. eth1
?  2

The installer can configure the networking and firewall rules on this machine with the configuration shown below. Default values are populated from the this machine's existing networking configuration.
 
If you DO NOT want to configure networking please set 'Configure networking on this machine' to No before proceeding. Do this by selecting option 'Do not configure networking' from the list below.
 
How would you like to proceed?:
1.      Proceed with the values shown
2.          Change Network interface | eth1
3.                 Change IP address | 192.168.152.10
4.                   Change Hostname | sat61fusor.example.com
5.               Change Network mask | 255.255.255.0
6.            Change Network address | 192.168.152.0
7.               Change Host Gateway | 192.168.121.1
8.           Change DHCP range start | 192.168.152.11
9.             Change DHCP range end | 192.168.152.254
10.              Change DHCP Gateway | 192.168.152.1
11.             Change DNS forwarder | 192.168.121.1
12.                    Change Domain | example.com
13.               Change Foreman URL | https://sat61fusor.example.com
14.             Change NTP sync host | clock.redhat.com
15.                  Change Timezone | America/New_York
16.       Change BMC feature enabled | false
17.      Change BMC default provider | ipmitool
18. Do not configure networking
19. Do not configure firewall
20. Cancel Installation
1

It would read better if we tweaked "Please select NIC on which you want provisioning enabled:" to be
"Select which NIC to use for provisioning:"

Need to drop 'the' from "Default values are populated from the this..."

We can cut down on the second paragraph. "If you DO NOT want to configure networking please set 'Configure networking on this machine' to No before proceeding. Do this by selecting option 'Do not configure networking' from the list below." to be
"If you DO NOT want fusor-installer to configure networking, select 'Do not configure networking'."

If we change the prompt "How would you like to proceed?:" to "Modify settings as needed, and then proceed with the installation:" we can then remove the 'Change' prefix on all of the settings. Saying Change <setting> 16 times in a row just becomes clutter, I think it's clear enough from the new string up top, and having the label next to its value that they're modifying settings.

"Cancel Installation" and "DHCP Gateway" are the only places we capitalize the second word (as long as it isn't an acronym), we should change 'Installation' and 'Gateway' to be lowercased to match the others.

"Timezone" should be two words, and have a space in between them, "Time zone".

So, it would look like this after the above suggestions:

Select which NIC to use for provisioning:
1. eth0
2. eth1
?  2

The installer can configure the networking and firewall rules on this machine with the configuration shown below. Default values are populated from this machine's existing networking configuration.
 
If you DO NOT want fusor-installer to configure networking, select 'Do not configure networking'.
 
Modify settings as needed, and then proceed with the installation:
1.      Proceed with the values shown
2.           Network interface | eth1
3.                  IP address | 192.168.152.10
4.                    Hostname | sat61fusor.example.com
5.                Network mask | 255.255.255.0
6.             Network address | 192.168.152.0
7.                Host gateway | 192.168.121.1
8.            DHCP range start | 192.168.152.11
9.              DHCP range end | 192.168.152.254
10.               DHCP gateway | 192.168.152.1
11.              DNS forwarder | 192.168.121.1
12.                     Domain | example.com
13.                Foreman URL | https://sat61fusor.example.com
14.              NTP sync host | clock.redhat.com
15.                  Time zone | America/New_York
16.        BMC feature enabled | false
17.       BMC default provider | ipmitool
18. Do not configure networking
19. Do not configure firewall
20. Cancel installation
1
Comment 1 jkim 2015-12-10 12:11:30 EST
Created PR
https://github.com/fusor/fusor-installer/pull/37
Comment 2 Tasos Papaioannou 2016-01-12 13:59:00 EST
The following suggestions weren't addressed:

***
"Cancel Installation" and "DHCP Gateway" are the only places we capitalize the second word (as long as it isn't an acronym), we should change 'Installation' and 'Gateway' to be lowercased to match the others.

"Timezone" should be two words, and have a space in between them, "Time zone".
***

Can we get those suggested changes as well? Current output is:

***
# rpm -q fusor-installer
fusor-installer-0.0.14-23.el7.noarch

# fusor-installer

The installer can configure the networking and firewall rules on this machine with the configuration shown below. Default values are populated from this machine's existing networking configuration.

If you DO NOT want to configure networking, select the option 'Do not configure networking' from the list below.

Modify settings as needed, and then proceed with the installation:
1.      Proceed with the values shown
2.           Network interface | eth1
3.                  IP address | 192.168.0.1
4.                    Hostname | dhcp-8-59-159.cfme.lab.eng.rdu2.redhat.com
5.                Network mask | 255.255.255.0
6.             Network address | 192.168.0.0
7.                Host Gateway | 10.8.59.254
8.            DHCP range start | 192.168.0.100
9.              DHCP range end | 192.168.0.199
10.               DHCP Gateway | 192.168.0.1
11.              DNS forwarder | 10.11.5.19
12.                     Domain | cfme.lab.eng.rdu2.redhat.com
13.                Foreman URL | https://dhcp-8-59-159.cfme.lab.eng.rdu2.redhat.com
14.              NTP sync host | clock.redhat.com
15.                   Timezone | US/Eastern
16.        BMC feature enabled | false
17.       BMC default provider | ipmitool
18. Do not configure networking
19. Do not configure firewall
20. Cancel Installation
***
Comment 3 Matt Reid 2016-01-12 15:37:31 EST
Looks like we gained a new entry with the second word capitalized since I opened this BZ.

7. Host Gateway | 10.8.59.254

'Gateway' in 'Host Gateway' should also be lowercased, along with the other 2 that haven't been updated yet.

10. DHCP Gateway
20. Cancel Installation
Comment 4 jkim 2016-01-14 11:34:20 EST
Created a PR
https://github.com/fusor/fusor-installer/pull/40
Comment 5 Tasos Papaioannou 2016-01-22 13:22:01 EST
We still have "Timezone" instead of "Time zone":

15.                   Timezone | US/Eastern

The other changes are all in place.
Comment 6 jkim 2016-01-22 14:53:38 EST
Created a PR
https://github.com/fusor/fusor-installer/pull/43
Comment 7 John Matthews 2016-01-22 16:09:01 EST
Compose: RHCI-6.0-RHEL-7-20160122.t.1-RHCI-x86_64-dvd1.iso
Comment 8 Tasos Papaioannou 2016-01-25 16:15:32 EST
VERIFIED on RHCI-6.0-RHEL-7-20160122.t.1.
Comment 9 Tasos Papaioannou 2016-03-08 12:45:44 EST
A recent change to the fusor-installer fields introduced a regression to the capitalization rules mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1277277#c0 :

7.        DHCP Network address |

should be:

7.        DHCP network address |
Comment 10 Derek Whatley 2016-06-21 14:18:30 EDT
Fixed capitalization rule violation.
Created PR at https://github.com/fusor/fusor-installer/pull/71
Comment 11 John Matthews 2016-06-23 16:02:24 EDT
Addressed in ISO Set:
QCI-1.2-RHEL-7-20160623.t.0-QCI-x86_64-dvd1.iso
QCIOOO-8.0-RHEL-7-20160623.t.0-QCIOOO-x86_64-dvd1.iso
Comment 12 Tasos Papaioannou 2016-06-27 11:45:40 EDT
I checked both QCI-1.2-RHEL-7-20160623.t.0 and fusor-QCI-1.2-RHEL-7-20160627.t.0, and the fix doesn't seem to have been merged.

****
Modify settings as needed, and then proceed with the installation:
1.      Proceed with the values shown
2.           Network interface | eth1
3.                    Hostname | localhost.cfme.lab.eng.rdu2.redhat.com
4.                  IP address | 
5.                Network mask | 
6.                Host gateway | 10.8.59.254
7.        DHCP Network address | 
****
Comment 16 Tasos Papaioannou 2016-07-07 12:59:26 EDT
Verified on QCI-1.2-RHEL-7-20160705.t.1.
Comment 22 errata-xmlrpc 2016-09-13 12:22:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.