Bug 1277300 - ActiveRecord::AssociationNotFoundError]: Association named 'hosts' was not found on MiqRegion
ActiveRecord::AssociationNotFoundError]: Association named 'hosts' was not fo...
Status: CLOSED DUPLICATE of bug 1275364
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
:
: 1279944 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 19:20 EST by Nandini Chandra
Modified: 2015-11-16 11:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 11:24:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2015-11-02 19:20:13 EST
Description of problem:
-----------------------
I have enabled C&U on my appliance and found this error logged in evm.log.
At this point,I am not sure how this is impacting roll up of C&U data.

[----] E, [2015-11-02T16:55:35.906463 #4630:33d998] ERROR -- : [ActiveRecord::AssociationNotFoundError]: Association named 'hosts' was not found on MiqRegion; perhaps you misspelled it?  Method:[rescue in deliver]
[----] E, [2015-11-02T16:55:35.906673 #4630:33d998] ERROR -- : /opt/rh/cfme-gemset/bundler/gems/rails-e2fcb2b4aec6/activerecord/lib/active_record/associations.rb:161:in `association'
/opt/rh/cfme-gemset/bundler/gems/rails-e2fcb2b4aec6/activerecord/lib/active_record/associations/builder/collection_association.rb:66:in `host_ids'
/var/www/miq/vmdb/app/models/mixins/aggregation_mixin.rb:107:in `aggregate_hardware'
/var/www/miq/vmdb/app/models/mixins/aggregation_mixin.rb:35:in `aggregate_cpu_speed'
/var/www/miq/vmdb/app/models/vim_performance_state.rb:131:in `capture_total'
/var/www/miq/vmdb/app/models/vim_performance_state.rb:60:in `capture'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:209:in `perf_capture_state'
/var/www/miq/vmdb/app/models/metric/ci_mixin/state_finders.rb:21:in `vim_performance_state_for_ts'
/var/www/miq/vmdb/app/models/metric/ci_mixin/state_finders.rb:41:in `ext_management_systems_from_vim_performance_state_for_ts'
/var/www/miq/vmdb/app/models/metric/rollup.rb:189:in `rollup_child_metrics'
/var/www/miq/vmdb/app/models/metric/rollup.rb:131:in `block in rollup_hourly'
/var/www/miq/vmdb/app/models/metric/rollup.rb:131:in `each'
/var/www/miq/vmdb/app/models/metric/rollup.rb:131:in `rollup_hourly'
/var/www/miq/vmdb/app/models/metric/ci_mixin/rollup.rb:91:in `block (2 levels) in perf_rollup'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
/var/www/miq/vmdb/app/models/metric/ci_mixin/rollup.rb:90:in `block in perf_rollup'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
/var/www/miq/vmdb/app/models/metric/ci_mixin/rollup.rb:77:in `perf_rollup'
/var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:151:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `loop'



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
5.5.0.8


How reproducible:
-----------------
Not sure


Steps to Reproduce:
-------------------
1.
2.
3.


Actual results:
--------------


Expected results:
----------------


Additional info:
----------------
Comment 2 Dave Johnson 2015-11-13 11:55:15 EST
*** Bug 1279944 has been marked as a duplicate of this bug. ***
Comment 3 Greg Blomquist 2015-11-16 11:24:15 EST

*** This bug has been marked as a duplicate of bug 1275364 ***

Note You need to log in before you can comment on or make changes to this bug.