Bug 1277303 - Rerunning the Ansible install will fail at times due to pacemaker.
Rerunning the Ansible install will fail at times due to pacemaker.
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Andrew Butcher
Xiaoli Tian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 19:27 EST by Ryan Howe
Modified: 2016-08-16 15:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-16 15:04:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-11-02 19:27:50 EST
Description of problem:
Rerunning the Ansible install will fail at times due to pacemaker. 

Version-Release number of selected component (if applicable):
3.0.x

How reproducible:
50%

Steps to Reproduce:
1. Stop All Openshift-master serivces 
2. Rerun the installer 


Actual results:
TASK: [openshift_examples | Import RHEL streams] ******************************
failed: [cpg-oshift2-master1.cisco.com] => {"changed": false, "cmd": ["oc", "create", "-n", "openshift", "-f", "/usr/share/openshift/examples/image-streams/image-streams-rhel7.json"], "delta": "0:00:00.252666", "end": "2015-11-02 11:53:28.248404", "failed": true, "failed_when_result": true, "rc": 1, "start": "2015-11-02 11:53:27.995738", "stdout_lines": [], "warnings": []}
stderr: The connection to the server openshiftv3.cisco.com:8443 was refused - did you specify the right host or port?
The connection to the server openshiftv3.cisco.com:8443 was refused - did you specify the right host or port?
The connection to the server openshiftv3.cisco.com:8443 was refused - did you specify the right host or port?
The connection to the server openshiftv3.cisco.com:8443 was refused - did you specify the right host or port?
The connection to the server openshiftv3.cisco.com:8443 was refused - did you specify the right host or port?
The connection to the server openshiftv3.cisco.com:8443 was refused - did you specify the right host or port?
The connection to the server openshiftv3.cisco.com:8443 was refused - did you specify the right host or port?
The connection to the server openshiftv3.cisco.com:8443 was refused - did you specify the right host or port?
The connection to the server openshiftv3.cisco.com:8443 was refused - did you specify the right host or port?


Expected results:

To run cleanly 

Additional info:

We are able to resolve this if we start all openshift-master services before running the install. 

The issue is something with the order in which Ansible configures pacemaker and openshift-master.

Note You need to log in before you can comment on or make changes to this bug.