Bug 127733 - Kate editor cannot save shortcut preference
Kate editor cannot save shortcut preference
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kdebase (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-12 22:29 EDT by reubendb
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 06:24:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description reubendb 2004-07-12 22:29:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
Kate editor cannot save shortcut preference. If you change the
shortcut in kate, and close and open kate after that, your custom
shortcut is gone, although it looks like ~/.kde/share/config/kate*rc
files is updated. 

Version-Release number of selected component (if applicable):
kdebase-3.1.3-5.2

How reproducible:
Always

Steps to Reproduce:
1. Open Kate
2. Select Settings->Configure Kate -> Editor --> Shortcut
3. Try changing delete line from CTRL-K to CTRL-Y (or anything).
4. Close kate, repeat step 1 & 2, you'll see that your custom shortcut
is gone, replaced by the default shortcut CTRl-K 

    

Actual Results:  Custom shortcut is gone, replaced by the default
shortcut CTRl-K 

Expected Results:  My preference shortcut should be saved

Additional info:

By the way, this also happes in Fedora Core 1.
Comment 1 Ngo Than 2004-07-19 06:24:05 EDT
it's fixed in FC2

Note You need to log in before you can comment on or make changes to this bug.