Bug 1277340 - bkr job-list --whiteboard should filter on whiteboard *substring* not exact match
bkr job-list --whiteboard should filter on whiteboard *substring* not exact m...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 21.2
: ---
Assigned To: Dan Callaghan
tools-bugs
: NeedsTestCase, Patch, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 00:46 EST by Dan Callaghan
Modified: 2015-11-22 22:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-22 22:53:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2015-11-03 00:46:46 EST
Description of problem:
According to the man page for bkr job-list, the --whiteboard option should filter by substring. However in 21.1 it only filters on exact matches.

Version-Release number of selected component (if applicable):
21.1

How reproducible:
easily

Steps to Reproduce:
1. Use bkr job-list to find some jobs using a substring of the whiteboard, for example if there is a job "Provision xyz.example.com" run "bkr job-list --whiteboard Provision"

Actual results:
Nothing matches

Expected results:
Command should list jobs matched on substring of whiteboard

Additional info:
Regression in 21.1 due to bug 1229937.
Comment 2 Dan Callaghan 2015-11-03 01:09:00 EST
The original version (before 21.1) also allowed SQL LIKE wildcards in the whiteboard substring. Probably this was just an implementation accident, it's not documented anywhere. But people might still be relying on it so we should preserve that too.
Comment 3 Dan Callaghan 2015-11-03 01:12:01 EST
http://gerrit.beaker-project.org/4472
Comment 6 matt jia 2015-11-22 22:53:11 EST
Beaker 21.2 has been released.

Note You need to log in before you can comment on or make changes to this bug.