Bug 1277359 - Data Tiering:Filenames with spaces are not getting migrated at all
Data Tiering:Filenames with spaces are not getting migrated at all
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: RHGS 3.1.2
Assigned To: Joseph Elwin Fernandes
nchilaka
: ZStream
Depends On: 1263619
Blocks: 1260783 1260923 1272207
  Show dependency treegraph
 
Reported: 2015-11-03 01:56 EST by nchilaka
Modified: 2016-09-17 11:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1263619
Environment:
Last Closed: 2016-03-01 00:50:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nchilaka 2015-11-03 01:56:14 EST
+++ This bug was initially created as a clone of Bug #1263619 +++

Description of problem:
=====================
Files which have spaces in their names are not getting demoted at all.
Looks like the delimiter was set.
I created some files with spaces in names which are not getting demoted, but files with no spaces in name were getting demoted.

For Eg:If I had a filename as "coca cola drink.txt", it was throwing following errors in tier log
[2015-09-16 10:06:40.801876] E [MSGID: 109037] [tier.c:194:tier_migrate_using_query_file] 0-ruby-tier-dht: failed parsing coca

[2015-09-16 10:06:40.801887] E [MSGID: 109037] [tier.c:194:tier_migrate_using_query_file] 0-ruby-tier-dht: failed parsing cola

[2015-09-16 10:06:40.801888] E [MSGID: 109037] [tier.c:194:tier_migrate_using_query_file] 0-ruby-tier-dht: failed parsing drink






Version-Release number of selected component (if applicable):
==========================================================
[root@zod glusterfs]# rpm -qa|grep gluster
glusterfs-client-xlators-3.7.4-0.33.git1d02d4b.el7.centos.x86_64
glusterfs-api-3.7.4-0.33.git1d02d4b.el7.centos.x86_64
glusterfs-fuse-3.7.4-0.33.git1d02d4b.el7.centos.x86_64
glusterfs-debuginfo-3.7.4-0.33.git1d02d4b.el7.centos.x86_64
glusterfs-3.7.4-0.33.git1d02d4b.el7.centos.x86_64
glusterfs-server-3.7.4-0.33.git1d02d4b.el7.centos.x86_64
glusterfs-cli-3.7.4-0.33.git1d02d4b.el7.centos.x86_64
glusterfs-libs-3.7.4-0.33.git1d02d4b.el7.centos.x86_64
[root@zod glusterfs]# gluster --version
glusterfs 3.7.4 built on Sep 12 2015 01:35:35
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@zod glusterfs]# 


How reproducible:
===============
easily

Steps to Reproduce:
===================
1.create a vol with quota enabled and attach tier vol and set ctr on 
2.set promo freq to say 100sec and demote to say 1000sec
3.Now create files with names having spaces.
4. Now don't access these files for say about 5min. This should mean they be demoted to cold.
But this doesnt happen and tier logs says "failed to parse"
Comment 3 nchilaka 2015-11-12 08:33:02 EST
1)I have tried on both nfsv3 and fuse with different combinations of spaces and some special characters. Now they are getting promoted/demoted.
hence moving to verified
Comment 5 errata-xmlrpc 2016-03-01 00:50:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.